Operating system name and version: Ubuntu
Version of smsd: 3.1.14
Smsd installed from: sources
Name and model of a modem / phone: Huawei E1552
Interface: USB

Hello, I already set-up my smstools application. There's no problem with receiving side. It works perfectly. But I was having trouble with sending messages. The files in outgoing directories were not moved to checked. That's why these messages were not sent. But when I manually moved the files from outgoing to checked directory, it worked. The file was sent. I was thinking of permission issue so I tried to change the modes of the directories from /var/spool/sms/* to 777 but still the problem was not solved. I read on the documentation that smsd will inherit the privileges of the user who run it. I used root but why it seems that it has no permission to move files? Any idea would be much appreciated.

This is my smsd.conf

devices = GSM1
logfile = /var/log/smsd.log
loglevel = 7

device = /dev/ttyUSB2
incoming = no
report_device_details =yes
'smsdconf' Syntax Highlight powered by GeSHi

This is the smsd.log file.

Thank you!