SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Sun Apr 11, 2021 12:23
SMSTools3 Community » Help and support Bottom

Unicode Message being sent and Plain Message is always failed.

Login and Post Reply

Page:  1

Author Post
Member
Registered:
Jan 2012
Location: Lahore / Pb / Punjab, Pakistan
Operating system name and version: Ubuntu 10.04.3 LTS
Version of smsd: 3.1.6 also tried on 3.1.14
Smsd installed from: Ubuntu apt-get install smstools
Name and model of a modem / phone: ZTE - MF100
Interface: USB

I am trying to send message but always failed ........

then tried same message on same number but in UNICODE and message sent.

Please help that way same modem is working on same number on UNICODE and not on plain text.


following is my log - please check PDU and advise

--------------------------------------
Failed First
--------------------------------------

2012-01-19 22:31:23,3, GSM2: The modem answer was not OK: +CMS ERROR: 500 (Unknown error)
2012-01-19 22:31:23,5, GSM2: Waiting 10 sec. before retrying
2012-01-19 22:31:33,6, GSM2: Checking if modem is ready
2012-01-19 22:31:33,7, GSM2: -> AT
2012-01-19 22:31:33,7, GSM2: Command is sent, waiting for the answer
2012-01-19 22:31:34,7, GSM2: <- OK
2012-01-19 22:31:34,6, GSM2: Pre-initializing modem
2012-01-19 22:31:34,7, GSM2: -> ATE0+CMEE=1
2012-01-19 22:31:34,7, GSM2: Command is sent, waiting for the answer
2012-01-19 22:31:34,7, GSM2: <- OK
2012-01-19 22:31:34,7, GSM2: -> AT+CSQ
2012-01-19 22:31:34,7, GSM2: Command is sent, waiting for the answer
2012-01-19 22:31:35,7, GSM2: <- +CSQ: 31,99 OK
2012-01-19 22:31:35,6, GSM2: Checking if Modem is registered to the network
2012-01-19 22:31:35,7, GSM2: -> AT+CREG?
2012-01-19 22:31:35,7, GSM2: Command is sent, waiting for the answer
2012-01-19 22:31:35,7, GSM2: <- +CREG: 0,1 OK
2012-01-19 22:31:35,6, GSM2: Modem is registered to the network
2012-01-19 22:31:35,6, GSM2: Selecting PDU mode
2012-01-19 22:31:35,7, GSM2: -> AT+CMGF=0
2012-01-19 22:31:35,7, GSM2: Command is sent, waiting for the answer
2012-01-19 22:31:36,7, GSM2: <- OK
2012-01-19 22:31:36,6, GSM2: Changing SMSC
2012-01-19 22:31:36,7, GSM2: -> AT+CSCA="+923330005150"
2012-01-19 22:31:36,7, GSM2: Command is sent, waiting for the answer
2012-01-19 22:31:36,7, GSM2: <- OK
2012-01-19 22:31:36,7, GSM2: -> AT+CMGS=57
2012-01-19 22:31:36,7, GSM2: Command is sent, waiting for the answer
2012-01-19 22:31:37,7, GSM2: <- >
2012-01-19 22:31:37,7, GSM2: -> 0011000C912903801434140000FF31C834A80EA2A3CBF2320B747EBFC9A0F65BEE4EBBCFA016C8FDA6B7EAEEF4F84D2E835A20383B9C9F36A70A.
2012-01-19 22:31:37,7, GSM2: Command is sent, waiting for the answer
2012-01-19 22:32:07,7, GSM2: <- +CMS ERROR: 500 (Unknown error)
2012-01-19 22:32:07,3, GSM2: The modem answer was not OK: +CMS ERROR: 500 (Unknown error)
2012-01-19 22:32:07,4, GSM2: Sending SMS to 923008414341 failed
2012-01-19 22:32:07,6, GSM2: Moved file /var/spool/sms/checked/out.0.1.18 to /var/spool/sms/failed/out.0.1.18
2012-01-19 22:32:07,6, GSM2: Checking device for incoming SMS
2012-01-19 22:32:07,6, GSM2: Checking if modem is ready
2012-01-19 22:32:08,7, GSM2: -> AT
2012-01-19 22:32:08,7, GSM2: Command is sent, waiting for the answer
2012-01-19 22:32:08,7, GSM2: <- OK
2012-01-19 22:32:08,6, GSM2: Pre-initializing modem
2012-01-19 22:32:08,7, GSM2: -> ATE0+CMEE=1

--------------------------------------
Successful - Unicode
--------------------------------------

2012-01-19 22:32:22,6, GSM2: Checking if modem is ready
2012-01-19 22:32:22,7, GSM2: -> AT
2012-01-19 22:32:22,7, GSM2: Command is sent, waiting for the answer
2012-01-19 22:32:23,7, GSM2: <- OK
2012-01-19 22:32:23,6, GSM2: Pre-initializing modem
2012-01-19 22:32:23,7, GSM2: -> ATE0+CMEE=1
2012-01-19 22:32:23,7, GSM2: Command is sent, waiting for the answer
2012-01-19 22:32:23,7, GSM2: <- OK
2012-01-19 22:32:23,7, GSM2: -> AT+CSQ
2012-01-19 22:32:23,7, GSM2: Command is sent, waiting for the answer
2012-01-19 22:32:24,7, GSM2: <- +CSQ: 31,99 OK
2012-01-19 22:32:24,6, GSM2: Checking if Modem is registered to the network
2012-01-19 22:32:24,7, GSM2: -> AT+CREG?
2012-01-19 22:32:24,7, GSM2: Command is sent, waiting for the answer
2012-01-19 22:32:24,7, GSM2: <- +CREG: 0,1 OK
2012-01-19 22:32:24,6, GSM2: Modem is registered to the network
2012-01-19 22:32:24,6, GSM2: Selecting PDU mode
2012-01-19 22:32:24,7, GSM2: -> AT+CMGF=0
2012-01-19 22:32:24,7, GSM2: Command is sent, waiting for the answer
2012-01-19 22:32:25,7, GSM2: <- OK
2012-01-19 22:32:25,6, GSM2: Changing SMSC
2012-01-19 22:32:25,7, GSM2: -> AT+CSCA="+923330005150"
2012-01-19 22:32:25,7, GSM2: Command is sent, waiting for the answer
2012-01-19 22:32:25,7, GSM2: <- OK
2012-01-19 22:32:25,7, GSM2: -> AT+CMGS=103
2012-01-19 22:32:25,7, GSM2: Command is sent, waiting for the answer
2012-01-19 22:32:26,7, GSM2: <- >
2012-01-19 22:32:26,7, GSM2: -> 0011000C912903801434140008FF590048006900200075002000740068006500720065002C00200067006F006F00640020006D006F0072006E0069006E00670020002D00200055006E00690063006F006400650020002D00200070006C006100790053004D00530A.
2012-01-19 22:32:26,7, GSM2: Command is sent, waiting for the answer
2012-01-19 22:32:31,7, GSM2: <- +CMGS: 177 OK
2012-01-19 22:32:31,5, GSM2: SMS sent, Message_id: 177, To: 923008414341, sending time 9 sec.
2012-01-19 22:32:31,6, GSM2: Moved file /var/spool/sms/checked/out.0.1.19 to /var/spool/sms/sent/out.0.1.19
2012-01-19 22:32:31,6, GSM2: Checking device for incoming SMS
2012-01-19 22:32:31,6, GSM2: Checking memory size
2012-01-19 22:32:31,7, GSM2: -> AT+CPMS?

Member
Registered:
Jan 2012
Location: Lahore / Pb / Punjab, Pakistan
Topic owner
since no one came up with solution, I tried on same setup, with different modem, HUAWAI EG162G.

and now its working.

then I tried again with ZTE-MF100 modem and faced same problem. on ZTE modem it sends only unicode messages but not plain text message.

I have bought 4 ZTE modems and I have to use them. Please help.

Member
Registered:
Jan 2012
Location: Lahore / Pb / Punjab, Pakistan
Topic owner
Hi, KEKE i need your attention. please help

Login and Post Reply

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.