SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Sun Feb 28, 2021 21:09
SMSTools3 Community » Help and support Bottom

[fixed in 3.1.15] Ubuntu, receive works, send fails without error.

Login and Post Reply

Page:  1

Author Post
Member
Registered:
Nov 2012
Location: United Kingdom
Operating system name and version: Ubuntu Server 12.10
Version of smsd: 3.1.14
Smsd installed from: package repository
Name and model of a modem / phone: GSM Modem for Wavecom Q2303A Module
Interface: USB

The modem will receive but not send.

The main smsd process exits with a core dump when I run it from the command line when there is a file in the outgoing spool folder.

smsd -s

I checked the core dump with gdb but there were no debug symbols in the executable so I got nothing useful.

The core said the problem was happening in vfprintf (so presumable a call to printf or sprintf somewhere in the code).

I tried to build from the ubuntu sources and run from there but cannot get the build to run with statistics included.

devices = GSM1
outgoing = /var/spool/sms/outgoing
checked = /var/spool/sms/checked
incoming = /var/spool/sms/incoming
logfile = /var/log/smstools/smsd.log
infofile = /var/run/smstools/smsd.working
pidfile = /var/run/smstools/smsd.pid
outgoing = /var/spool/sms/outgoing
checked = /var/spool/sms/checked
failed = /var/spool/sms/failed
incoming = /var/spool/sms/incoming
sent = /var/spool/sms/sent
stats = /var/log/smstools/smsd_stats

trust_outgoing = yes

loglevel = 7
receive_before_send = no
autosplit = 3

[GSM1]
device = /dev/ttyUSB0
incoming = yes
outgoing = yes
smsc = 447802002606
baudrate = 9600
   
 
'smsdconf' Syntax Highlight powered by GeSHi


There are no entries in the log file for sending.

The file placed in the outgoing spool is:

To: 44xxxxxxxxxxx

Hello david
 
'smsdconf' Syntax Highlight powered by GeSHi


Where xxxxxxxxxxx is my UK mobile number with the leading 0 removed (exactly as it appears in the received message).


« Last edit by woakesd on Sat Nov 24, 2012 18:13, 100 months ago. »
Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Upgrade to the 3.1.15.

Member
Registered:
Nov 2012
Location: United Kingdom
Topic owner
Thanks, I downloaded and installed 3.1.15 and it works. I've reported this on Ubuntu's forums.

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Thanks, and sorry for the bug :oops: .

Ubuntu maintainers already know the issue, and have 3.1.15 available. Because of distributions, and severity of the bug, the 3.1.15 has only the bug fixed and nothing more changes which are pending.

Login and Post Reply

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.