SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Thu Mar 04, 2021 09:19
SMSTools3 Community » Help and support Bottom

Wavecom Modem + Smstool3

Login and Post Reply

Page:  1

Author Post
Member
Registered:
Apr 2013
Location: Bangalore/Karnataka, India
Operating system name and version: RHEL 5.8
Version of smsd: 3.1.15
Smsd installed from: sources / package repository / from elsewhere...Source
Name and model of a modem / phone: Wavecom Fargo Maestro 20
Interface: serial / USB / some adapter...Serial

I am using Wavecom Fargo Maestro 20 and trying to send sms via smstools .
If I start minicom it triggers command to modem . But I am not able to send SMS


here the logs


2013-04-19 10:44:00,7, smsd: Done: startup_check (shell), execution time 0 sec., status: 0 (0)
2013-04-19 10:44:00,4, smsd: File mode creation mask: 027 (0640, rw-r-----).
2013-04-19 10:44:00,5, GSM1: Modem handler 0 has started. PID: 6069.
2013-04-19 10:44:00,5, GSM1: Using check_memory_method 1: CPMS is used.
2013-04-19 10:44:00,5, smsd: Outgoing file checker has started. PID: 6068.
2013-04-19 10:44:00,7, smsd: All PID's: 6068,6069
2013-04-19 10:44:00,6, GSM1: I have to send 1 short message for /var/spool/sms/checked/send_Yp5533
2013-04-19 10:44:00,6, GSM1: Checking device for incoming SMS
2013-04-19 10:44:00,6, GSM1: Checking if modem is ready
2013-04-19 10:44:00,7, GSM1: -> AT
2013-04-19 10:44:21,7, GSM1: Command is sent, waiting for the answer
2013-04-19 10:44:21,5, smsd: Moved file /var/spool/sms/outgoing/send_UF6086 to /var/spool/sms/checked
2013-04-19 10:44:26,7, GSM1: put_command expected (OK)|(ERROR), timeout occurred. 1.
2013-04-19 10:44:26,7, GSM1: <-
2013-04-19 10:44:26,7, GSM1: ->
2013-04-19 10:44:26,7, GSM1: Command is sent, waiting for the answer
2013-04-19 10:44:31,7, GSM1: put_command expected (OK)|(ERROR), timeout occurred. 2.
2013-04-19 10:44:31,7, GSM1: <-
2013-04-19 10:44:31,7, GSM1: -> AT
2013-04-19 10:44:31,7, GSM1: Command is sent, waiting for the answer
2013-04-19 10:44:36,7, GSM1: put_command expected (OK)|(ERROR), timeout occurred. 3.
2013-04-19 10:44:36,7, GSM1: <-
2013-04-19 10:44:36,7, GSM1: ->
2013-04-19 10:44:36,7, GSM1: Command is sent, waiting for the answer
2013-04-19 10:44:42,7, GSM1: put_command expected (OK)|(ERROR), timeout occurred. 4.

If minicom not running it will stuck at

2013-04-19 10:44:00,6, GSM1: Checking if modem is ready
2013-04-19 10:44:00,7, GSM1: -> AT


And here my config file

devices = GSM1
logfile = /var/log/smsd.log
loglevel = 7
outgoing = /var/spool/sms/outgoing
checked = /var/spool/sms/checked
failed = /var/spool/sms/failed
incoming = /var/spool/sms/incoming
sent = /var/spool/sms/sent
delaytime = 10
errorsleeptime = 20
blocktime = 100
autosplit = 3
receive_before_send = yes
[GSM1]
device = /dev/ttyS0
incoming = yes
outgoing = yes
baudrate = 9600
init = AT+CSQ
rtscts = yes

Member
Registered:
Apr 2013
Location: Bangalore/Karnataka, India
Topic owner
If I do echo 'atd1234567890;' > /dev/ttyS0 it doesnt work .. Incase minicom is open it works

Member
Registered:
Apr 2013
Location: Bangalore/Karnataka, India
Topic owner
I could able to clear this after setting bellow to ttyS0
stty -F /dev/ttyS0 9600 hupcl -crtscts icrnl ixon opost onlcr isig icanon iexten echo echoe echok -echonl -noflsh -xcase -tostop -echoprt -ignpar

Now smsd service gives error like below

2013-04-22 11:44:44,6, GSM1: Pre-initializing modem
2013-04-22 11:45:01,3, GSM1: Unexpected input: OK OK AT OK OK OK OK OK OK OK OK AT OK OK OK OK OK OK OK OK AT OK OK OK OK OK OK OK OK AT OK OK OK OK OK OK OK OK OK OK OK AT OK
2013-04-22 11:45:01,7, GSM1: -> ATE0+CMEE=1;+CREG=2
2013-04-22 11:45:01,7, GSM1: write_to_modem: device busy, waiting
2013-04-22 11:45:14,7, GSM1: Command is sent, waiting for the answer
2013-04-22 11:45:14,7, GSM1: put_command expected (OK)|(ERROR), timeout occurred. 1.
2013-04-22 11:45:14,7, GSM1: <-
2013-04-22 11:45:14,7, GSM1: <-
2013-04-22 11:45:14,3, GSM1: Modem did not accept the pre-init string
2013-04-22 11:45:14,6, GSM1: Checking if modem needs PIN
2013-04-22 11:45:19,3, GSM1: Unexpected input: OK OK OK O OK OK OK O A TE0+CMEE=1;+CREG=2 O
2013-04-22 11:45:19,7, GSM1: -> AT+CPIN?
2013-04-22 11:45:19,7, GSM1: -> AT+CPIN?
2013-04-22 11:45:19,7, GSM1: write_to_modem: device busy, waiting
2013-04-22 11:45:27,7, GSM1: write_to_modem: device busy, waiting
2013-04-22 11:45:32,7, GSM1: Command is sent, waiting for the answer
2013-04-22 11:45:32,7, GSM1: put_command expected (READY)|( PIN)|( PUK)|(ERROR), timeout occurred. 2.
2013-04-22 11:45:32,7, GSM1: <-
2013-04-22 11:45:32,2, GSM1: PIN handling: expected READY, modem answered
2013-04-22 11:45:32,2, GSM1: Modem handler 0 terminated abnormally. PID: 2921.

Member
Registered:
Apr 2013
Location: Bangalore/Karnataka, India
Topic owner
I have changed settings

[GSM1]
device = /dev/ttyS0
incoming = yes
outgoing = yes
memory_start = 0
baudrate = 9600
report = yes
rtscts = yes
read_timeout = 60
init = AT+CMEE=1
init2 = AT+CPMS="SM"
signal_quality_ber_ignore = yes


Now error log is different

2013-04-23 09:05:52,6, GSM1: Checking device for incoming SMS
2013-04-23 09:05:52,6, GSM1: Checking if modem is ready
2013-04-23 09:05:52,7, GSM1: -> AT
2013-04-23 09:05:52,7, GSM1: Command is sent, waiting for the answer
2013-04-23 09:05:53,7, GSM1: <- OK
2013-04-23 09:05:53,6, GSM1: Pre-initializing modem
2013-04-23 09:05:53,6, GSM1: Pre-initializing modem
2013-04-23 09:05:53,7, GSM1: -> ATE0+CMEE=1;+CREG=2
2013-04-23 09:05:53,7, GSM1: Command is sent, waiting for the answer
2013-04-23 09:05:53,7, GSM1: <- OK +CREG: 5,"065C","A96B"
2013-04-23 09:05:53,6, GSM1: Initializing modem
2013-04-23 09:05:53,6, GSM1: Initializing modem
2013-04-23 09:05:53,7, GSM1: -> AT+CMEE=1
2013-04-23 09:05:53,7, GSM1: Command is sent, waiting for the answer
2013-04-23 09:05:54,7, GSM1: <- OK
2013-04-23 09:05:54,7, GSM1: -> AT+CPMS="SM"
2013-04-23 09:05:54,7, GSM1: Command is sent, waiting for the answer
2013-04-23 09:05:54,7, GSM1: <- +CPMS: 15,25,15,25 OK
2013-04-23 09:05:54,7, GSM1: -> AT+CSQ
2013-04-23 09:05:54,7, GSM1: Command is sent, waiting for the answer
2013-04-23 09:05:55,7, GSM1: <- +CSQ: 24,0 OK
2013-04-23 09:05:55,6, GSM1: Signal Strength Indicator: (24,0) -65 dBm (Excellent)
2013-04-23 09:05:55,6, GSM1: Signal Strength Indicator: (24,0) -65 dBm (Excellent)
2013-04-23 09:05:55,6, GSM1: Checking if Modem is registered to the network
2013-04-23 09:05:55,7, GSM1: -> AT+CREG?
2013-04-23 09:05:55,7, GSM1: Command is sent, waiting for the answer
2013-04-23 09:05:55,7, GSM1: <- +CREG: 2,5,"065C","A96B" OK
2013-04-23 09:05:55,6, GSM1: Modem is registered to a roaming partner network
2013-04-23 09:05:55,6, GSM1: Selecting PDU mode
2013-04-23 09:05:55,6, GSM1: Selecting PDU mode
2013-04-23 09:05:55,7, GSM1: -> AT+CMGF=0
2013-04-23 09:05:55,7, GSM1: Command is sent, waiting for the answer
2013-04-23 09:05:56,7, GSM1: <- OK
2013-04-23 09:05:56,6, GSM1: Checking memory size
2013-04-23 09:05:56,6, GSM1: Checking memory size
2013-04-23 09:05:56,7, GSM1: -> AT+CPMS?
2013-04-23 09:05:56,7, GSM1: Command is sent, waiting for the answer
2013-04-23 09:05:56,7, GSM1: <- +CPMS: "SM",15,25,"SM",15,25 OK
2013-04-23 09:05:56,6, GSM1: Command failed.
2013-04-23 09:05:56,6, GSM1: No SMS received (reading interrupted)


resh

Login and Post Reply

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.