SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Fri Oct 30, 2020 03:46
SMSTools3 Community » Help and support Bottom

Anyone have any newer INIT strings for 4G Wavecom devices?

Login and Post Reply

Page:  1

Author Post
Member
Registered:
Apr 2017
Location: Fort Collins, CO, United States of America
I have been trying init strings all day for my 4G Wavecom device :( I can send and receive SMS's but this constant traffic back and forth from the modem is bogging down my daemon...

I am encountering the old:

2017-04-22 12:52:38,7, GSM1: Command is sent, waiting for the answer
2017-04-22 12:52:38,7, GSM1: <- +CPMS: "SM",1,30,"SM",1,30,"SM",1,30 OK
2017-04-22 12:52:38,6, GSM1: Used memory is 1 of 30
2017-04-22 12:52:38,6, GSM1: Trying to get stored message 1
2017-04-22 12:52:39,7, GSM1: -> AT+CMGR=1
2017-04-22 12:52:39,7, GSM1: Command is sent, waiting for the answer
2017-04-22 12:52:39,7, GSM1: <- +CMS ERROR: 321 (Invalid memory index)
2017-04-22 12:52:39,6, GSM1: Trying to get stored message 2
2017-04-22 12:52:39,7, GSM1: -> AT+CMGR=2
2017-04-22 12:52:39,7, GSM1: Command is sent, waiting for the answer
2017-04-22 12:52:39,7, GSM1: <- +CMS ERROR: 321 (Invalid memory index)
2017-04-22 12:52:39,6, GSM1: Trying to get stored message 3
2017-04-22 12:52:40,7, GSM1: -> AT+CMGR=3
2017-04-22 12:52:40,7, GSM1: Command is sent, waiting for the answer
2017-04-22 12:52:40,7, GSM1: <- +CMS ERROR: 321 (Invalid memory index)
2017-04-22 12:52:40,6, GSM1: Trying to get stored message 4
2017-04-22 12:52:40,7, GSM1: -> AT+CMGR=4
2017-04-22 12:52:40,7, GSM1: Command is sent, waiting for the answer
2017-04-22 12:52:40,7, GSM1: <- +CMS ERROR: 321 (Invalid memory index)
2017-04-22 12:52:40,6, GSM1: Trying to get stored message 5
2017-04-22 12:52:41,7, GSM1: -> AT+CMGR=5

Any help would be appreciated...

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Try with a modem setting memory_start = 0.

If it does not help for some reason, try a setting check_memory_method = 31.

Member
Registered:
Apr 2017
Location: Fort Collins, CO, United States of America
Topic owner
Thank you kindly, that seemed to do the trick!!! The memory start = 0...

Another donation on the way!!! You have saved me....

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
You are welcome!

If your modems receives large number of messages, the check_memory_method = 31 is still recommended as it is much faster than default method.

Login and Post Reply

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.