SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Sat Sep 26, 2020 16:00
SMSTools3 Community » Help and support Bottom

How to send latin characters?

Login and Post Reply

Page:  1

Author Post
Member
Registered:
Oct 2019
Location: Denmark
Windows 10:
3.1.21:
Huawei E20:
USB

Spanish characters are sent without the accent. For example "día" is sent as "dia"... no accent on the "i".

How do I fix this?

The config file:
**********************************

# Example smsd.conf. Read the manual for a description

devices = GSM1
logfile = /var/log/smsd.log
loglevel = 7
store_received_pdu = 3
store_sent_pdu = 3
incoming_utf8 = yes
alphabet = UTF
delaytime = 1
hangup_incoming_call = yes
max_continuous_sending = 20
receive_before_send = yes

[GSM1]
device = /dev/com6
incoming = yes
decode_unicode_text = yes
baudrate = 460800



The outgoing message
********************************
To: 4525850567
Alphabet: UTF-8

día

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
By default, and because of historical reasons, the smstools tries to stay using the GSM alphabet, if an optical replacement for the character outside the GSM alphabet is found. This is why your í is changed to i.

You can disable the optical replacement by using the modem setting cs_convert_optical = no. If you have many modems, you can use the default section, which affects for all modems, like this:

[default]
cs_convert_optical = no
 
'smsdconf' Syntax Highlight powered by GeSHi


Member
Registered:
Oct 2019
Location: Denmark
Topic owner
Hi Administrator,

Thank you, thank you ... and thank you!

Login and Post Reply

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.