SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Fri Sep 22, 2017 11:39
SMSTools3 Community » Bug reports Bottom

Smsd ignores group option

Login and Post Reply

Page:  1

Author Post
Member
Registered:
Dec 2011
Location: Russian Federation
I know that Linux uses uucp:uucp (66:66) for modem devices(i.e. /dev/tty*). But FreeBSD, for example, uses uucp:dialer (66:68\).
Good way to solve this small problem is to set group to dialer. But here is problem.
Smsd doesn't do it. Wether you set it in commandline args or in config file. No way. It just runs as uucp:uucp.

Here is config:
# cat smsd.conf
devices = GSM1
logfile = /var/log/smsd/smsd.log
loglevel = 7
stats = /var/spool/sms/stats
stats_interval = 0

user = uucp
group = dialer

[GSM1]
device = /dev/ttyU0.2
init = AT^CURC=0
ussd_convert = 2
read_timeout = 10
 
'smsdconf' Syntax Highlight powered by GeSHi


Here is commandline args which were set at start
# ps ax | grep sms
21804  -  Ss       0:00.09 /usr/local/bin/smsd -c/usr/local/etc/smsd.conf -p/var/run/smsd/smsd.pid -i/var/run/smsd/smsd.working -l/var/log/smsd/smsd.log -uuucp -gdialer
21805  -  I        0:00.00 /usr/local/bin/smsd -c/usr/local/etc/smsd.conf -p/var/run/smsd/smsd.pid -i/var/run/smsd/smsd.working -l/var/log/smsd/smsd.log -uuucp -gdialer
'smsdconf' Syntax Highlight powered by GeSHi



But in log it tells uucp:uucp
# head /var/log/smsd/smsd.log
2013-10-23 11:21:06,2, smsd: Smsd v3.1.15 started.
2013-10-23 11:21:06,2, smsd: Running as uucp:uucp.
......
'smsdconf' Syntax Highlight powered by GeSHi


As result it doesn't have access to gsm modem.
How to make it set group to dialer?
P.S. I know about possible workarounds. But, the problem is smsd ignores groups option.


« Last edit by timp on Wed Oct 23, 2013 07:50, 47 months ago. »
Member
Registered:
Dec 2011
Location: Russian Federation
Topic owner
timp wrote
... But FreeBSD, for example, uses uucp:dialer (66:68)...

Sorry, the problem was different! But the main idea is still actual.

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
User and group only works when smsd is started by root.

Member
Registered:
Dec 2011
Location: Russian Federation
Topic owner
keke wrote
User and group only works when smsd is started by root.

Could you explain please? As I know when system boots it starts smsd as root, doesn't it?

Member
Registered:
Dec 2011
Location: Russian Federation
Topic owner
keke wrote
User and group only works when smsd is started by root.

I still can't understand why it doesn't take another privileges.
Of course, I start it as root. Of course, system starts it as root while booting.
But smsd completely ignores -ux and -gx parameters and ignores user=x and group=x from smsd.conf.

I can take an access for you to virtual machine to prove it.

Member
Registered:
Dec 2011
Location: Russian Federation
Topic owner
timp wrote
keke wrote
User and group only works when smsd is started by root.

I still can't understand why it doesn't take another privileges.
Of course, I start it as root. Of course, system starts it as root while booting.
But smsd completely ignores -ux and -gx parameters and ignores user=x and group=x from smsd.conf.

I can take an access for you to virtual machine to prove it.

Hmm, looks like it's problem in freebsd's rc.d script. I'll try to investigate and then report back.

Member
Registered:
Dec 2011
Location: Russian Federation
Topic owner
Yes. There was a problem in FreeBSD's rc.d script. It was fixed in r359425

Login and Post Reply

Page:  1

SMSTools3 Community » Bug reports Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.