SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Fri Jun 14, 2024 18:38
SMSTools3 Community » Help and support Bottom

Siemens tc35 - MODEM IS NOT REGISTERED, WAITING 1 SEC. BEFORE RETRYING in LOOP

Login and Post Reply

Page:  1

Author Post
Member
Registered:
Nov 2013
Location: Trino, Italy
Hello.
I am using the last smsd version on a Debian Linux Lenny installed from the package.
My modem is a board with Siemens TC35 Module attached on the /dev/ttyS0
In minicom I am able to send sms, but with smstool I can't.
I keeps to obtain MODEM IS NOT REGISTERED, WAITING 1 SEC. BEFORE RETRYING and it not sends any sms.
The first time it asks signal to the modem it is registered correctly.

My LOG is:


My Config file:


Thanks a lot.
Ivan.

Member
Registered:
Nov 2013
Location: Trino, Italy
Topic owner
I have take a look to the source code.
In the modeminit.c why the first strstr fails? According to the LOG, "answer" string shoult contain AT+CREG? +CREG: 0,1 OK.



Member
Registered:
Feb 2014
Location: India
I am stuck with the same error, please help.

Member
Registered:
Feb 2014
Location: India
Resolved this issue by setting the init parameter as
init = ATE0

Member
Registered:
Dec 2014
Location: United States of America
Looks like issue was introduced with 3.1.14, more info at http://smstools3.kekekasvi.com/topic.php?id=861.

Login and Post Reply

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.