We tried migrate to 3.1.15 from special version 3.1.14-VVV-3 created here : http://smstools3.kekekasvi.com/topic.php?id=557&page=2.
During this migration server PC itself, Windows OS , and Cygwin version have been changed up to most recent ones.

However we have faced with same error described in http://smstools3.kekekasvi.com/topic.php?id=557&page=2 :

Error appeared for the first time after 3 weeks of working.
I have reinstalled previously accepetd version : 3.1.14-VVV-3.
( it worked fine for us on old server ).

Also I have found that such error appear not only on Cygwin : http://smstools3.kekekasvi.com/topic.php?post=5006#post5006.

Keke, could you please include fixes of 3.1.14-VVV-3 into main smsd verison ?
It proved great stability during few years..

Thank you very much for your support!