SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Sat May 25, 2024 11:20
SMSTools3 Community » Help and support Bottom

[changed in 3.1.12] Bulk SMS

  This topic is locked

Page:  1

Author Post
Member
Registered:
Apr 2010
Location: Buenos Aires, Argentina
Operating system name and version: Windows XP with Cygwin
Version of smsd: 3.1.7
Smsd installed from: sources
Name and model of a modem / phone: Huawei E176
Interface: USB


Hello Keke:

I return to this forum, with more questions and with more problems.

I explain you my problem: I need to send a lot of sms per minute (the maximun that I can send). but with a send report of each sms-

I tried to use a gateway Multitech, in the first place (when I contact you), and now I use a laptop and a PC with Cygwin and modems Huawei inserte on usb ports.

I tried with one, two and three modems, and the number of sms reach at least 5 or 6 sms per minute (all the three modems), there is : 2 per minute per modem.

When I connect another modem, the number of send sms decreases, and the dialog with the modems increases, but not effectibly

Is there a minimun configuration to reach the maximun number of sms with reports?

I send you the smsd config file, where I tried to configure "the minimun dialog", with the modems, but I not get the solution.

can you help me?
thanks




devices = GSM1, GSM2, GSM3
logfile = /var/log/smsd.log
report = /var/spool/sms/reports
loglevel = 7

[default]
incoming = yes
init = AT+CNMI=2,0,0,2,0
report = yes
baudrate = 115200
check_memory_method = 0
check_network = 0
detect_message_routing = no
detect_unexpected_input = no
max_continuous_sending = 3000
read_timeout = 2
routed_status_report_cnma = no
rtscts = no
send_delay = 0


[GSM1]
device = /dev/com6

[GSM2]
device = /dev/com5

[GSM3]
device = /dev/com5

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Perhaps you have some problem with the driver of a port(s). The number of modems should not decrease the performance.

In your setup there is /dev/com5 used for GSM2 and GSM3, but probably this is a typo, as smsd should detect it and report as an error.

You could show the log with three modems sending, so I can see what is actually happening and how long any actions take. If necessary, use the Private tag to protect the data.

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
A piece of a log can be included in the posting, using the Code block. However, It is also ok to use email, especially with large files.

Your destination numbers starts with "116...". Are you sure that this is correct, which means that international format is used? With some messages the sending time is 1 or 2 seconds, which sounds too small. Perhaps this has something to do with the number format.

It seems that the smsd was started twice, which should not be done.

You have selected check_memory_method 0, but it seems that the modem supports the default value. You could try with value 31, it's much better if it works. If you continue with a default value (1), the modem probably needs a setting memory_start = 0. The current setting is causing unnecessary delay for sending.

Your front-end application is creating outgoing files slowly. The smsd can spool one message per second, but in the log there is much longer delay.

There is also some problems with a checked directory, but I check this more later.

Member
Registered:
Apr 2010
Location: Buenos Aires, Argentina
Topic owner
Keke :

I send you by mail a new log test, with only one modem

- I modify chek_memory_method to 31 . And it seems work fine

- I tried two number format: 1566050000 and 1166050000. The first 40 sms are with the first format

about the outgoing file : this file contains 10.000 files and I prepare it, always before I start sending.

Never this file was empty.

In this log I get 2/3 sms per minute. It seems to poor.

Lextor

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
lextor wrote
about the outgoing file : this file contains 10.000 files and I prepare it, always before I start sending.

That's it. Your system uses memory and especially the disk very heavily. This is because the oldest file is processed first, and smsd should check every file. I might add an option for disabling this, but in any case it's not a good idea to handle 10.000 files simultaneously.

Also the priorizing is checked, and it takes time with 10k files. This can be disabled with a global setting ignore_outgoing_priority = yes.

You have some kind of a script which creates those outgoing files? It could monitor the checked directory, and if there is more than 100 files spooled, the script could wait little bit...

Member
Registered:
Apr 2010
Location: Buenos Aires, Argentina
Topic owner
Keke

EUREKA!. 6/8 sms per minute!!

I never thinked in the outgoing and checked files.

Im going to try with 3 modems again and tell you the results

One last question Have you an idea why in this last two tests, the modems didnt receive reports?

Lextor

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
With a large number of files in the spooler, you could try this change to the code: in the file extras.c locate the following and insert the line ( break; ) which is shown bold and red:

             // 3.1.6: Files with the same timestamp: compare names:
             if (found && statbuf.st_mtime == mtime)
               if (strcmp(fname, tmpname) > 0)
                 mtime = 0;

             if (mtime == 0 || statbuf.st_mtime < mtime)
             {
#ifdef DEBUGMSG
 printf("taken\n");
#endif
               strcpy(fname, tmpname);
               mtime = statbuf.st_mtime;
               found = 1;

               break;

             }
#ifdef DEBUGMSG
             else
               printf("leaved\n");
#endif


lextor wrote
One last question Have you an idea why in this last two tests, the modems didnt receive reports?

Perhaps reports are not supported, or you have incorrect CNMI setting. Check from the manual which kind of setting is required.

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
lextor wrote
Dear Keke:

I have a new problem:

After the solution of the number of sms per minute (with the minor amount of sms in outoing directory), and the 31 in the check_memory_method, the program works faster.

But from that moment, never received a Status report any more.

before these changes , the reports was receveid fine with the same modems.

I send you one log and the smsd config file.

something changes, but I dont know what

Thank you for your help

Lextor

If you cannot find the previous setting, which were working, you could start smsd with report_device_details = yes and show those details here.

Perhaps your modem stores reports into the different memory, and you have used dual-memory handler.

Do you have a manual for this modem, so the CNMI setting can be verified?

Member
Registered:
Apr 2010
Location: Buenos Aires, Argentina
Topic owner
Dear KEKE

I send you by mail the log file with the "report_device_details"

I am looking for a manual of the modems for the CNMI settings

I tell you if I found something

Thanks for your pattience

Lextor

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Quote
2010-06-11 11:44:30,7, GSM1: # Preferred message storage, list of supported mem's:
2010-06-11 11:44:30,7, GSM1: -> AT+CPMS=?
"2010-06-11 11:44:30,7, GSM1: <- +CPMS: (""ME"",""MT"",""SM"",""SR""),(""ME"",""MT"",""SM"",""SR""),(""ME"",""MT"",""SM"",""SR"")"

There is a SR memory available, so you could use the dual-memory handler:

primary_memory = SM
secondary_memory = SR



Another issue:
Quote
2010-06-11 11:44:51,5, GSM1: Cannot convert 12. character <F4> 0xFFFFFF93 to GSM, you might need to update the translation tables.
2010-06-11 11:44:51,5, GSM1: Cannot convert 17. character <F6> 0xFFFFFF94 to GSM, you might need to update the translation tables.

Your SMS contains some characters which are not available in GSM alphabet, and also they do not have optical replacement. Those characters are ignored. Because the receiver gets different looking message than you have sent, you could check and modify what you are sending.

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Quote
Dear Keke:.

I cant find the problem

I test different smsd.conf files ( the last is the attached file), but I never received a report file

I send you a log file too

thank you again for your help

Lextor




There is a SR memory working, but it's empty. Your messages had report requested, and if you are sure that you had reports received, before changing the configuration, I think that the manual of a modem and of a CNMI command is the only thing which can resolve this.

This may also be an operator depended issue, are you still using SIM cards from the same operator, and sending to the same (or similar) numbers, as in the past when reports were working?

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
lextor wrote
Dear Keke

The modems are the same, the operator and the chips are the same.

I try now with a more simple smsd.conf (I send it you), and also delete the reports folder

with this configuration I received reports in the incomming folder. But all in failure

I detect an abnormal behavior in the network, because I send a message with my personal phone and didnt received the report.

I try again with the smsd program when I received fine the reports in my phone.

I send you the log, because I note again a slow rate of messages ( I mantain the outoing folder with 100 sms at least)

thanks again

Lextor

How do you note a slow rate, especially remarkable slow rate?

The mainspooler handles one message per second which is a normal speed.

The sending time varies, but it's caused by the network and smsd cannot do anything for it. There has also been network errors and then smsd will wait 10 seconds and retry. In some cases retrying has helped, but there is also permanently failed messages.

You do not need dual-memory handler, and also receive_before_send is unnecessary. When your modem gives status reports, they are stored into the SM memory. However, most messages do not receive report, and smsd cannot do nothing for this. You could contact your GSM operator which may explain why reports are not received for all messages. There is also a support forum of Huawei existing, if missing reports are caused by the modem. Those reports which you have received are useless, because the status is always "0x70 unknown". The operator may also explain why "real" reports are not delivered.

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
There is now a new version 3.1.12 available. As you are running couple of modems on Cygwin, you could install the new version (if still using this software with a heavy load). The new version should work much better on Cygwin, but still there are limits because the file system on Windows is slow.

I have closed some old topics, feel free to open a new topic if necessary.

  This topic is locked

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.