SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Sat May 25, 2024 10:43
SMSTools3 Community » Help and support Bottom

[answered] vodafone usb modem

  This topic is locked

Page:  1  2  Next

Author Post
Member
Registered:
Jun 2010
Location: Egypt
Operating system name and version: fedora 13 - 64 bit
Version of smsd: 3.1.5.4.fc13
Smsd installed from: package repository
Name and model of a modem / phone: 12d1:1003 Huawei Technologies Co., Ltd. E220 HSDPA Modem / E270 HSDPA/HSUPA Modem
Interface: /dev/ttyUSB0

i have never been able to send an sms message but i can talk to my modem via minicom. sometimes smstools can talk to my modem. however, whenever smstools sends the box like character i get problems:

2010-06-17 18:38:03,7, GSM1: -> ▒
2010-06-17 18:38:03,7, GSM1: Command is sent, waiting for the answer

and then i get entries in my log like:
Command is sent, waiting for the answer
or
Modem is not ready to answer commands (Timeouts: 1)

any help would be highly appreciated

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
I doubt that this is caused by the bug in the smsd: string manipulation does not work properly when running on latest 64bit Ubuntu (with Intel processor). Perhaps this bug affect on Fedora too.

Can you download the latest version 3.1.9 and compile it from sources?

Member
Registered:
Jun 2010
Location: Egypt
Topic owner
hi
i had installed smstools from fedora repos and i hope i didnt muck things up by doing this. i downloaded and compiled the version you recommended. then i _copied_ smsd to /usr/bin overwriting the old version.

the logs now show this:


2010-06-18 21:32:15,7, GSM1: -> 01000A91101053000200000138▒
2010-06-18 21:32:15,7, GSM1: Command is sent, waiting for the answer
2010-06-18 21:32:41,7, GSM1: <- 01000A91101053000200000138 ^RSSI:9 ^RSSI:9 ^RSSI:9 ^RSSI:9 ^RSSI:9 ^RSSI:9 ^RSSI:9 ^RSSI:9 ^RSSI:9 +CMS ERROR: 500 (Unknown error)
2010-06-18 21:32:41,3, GSM1: The modem answer was not OK: 01000A91101053000200000138^RSSI:9^RSSI:9^RSSI:9^RSSI:9^RSSI:9^RSSI:9^RSSI:9^RSSI:9^RSSI:9+CMS ERROR: 500 (Unknown error)
2010-06-18 21:32:41,4, GSM1: Sending SMS to <mobile_number> failed

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Could it be possible that you had the setting mode = old in the smsd.conf, and you tried to send SMS containing only single character? If this is the case, remove that mode = old line, restart smsd and try again.

Member
Registered:
Jun 2010
Location: Egypt
Topic owner
yes and yes :D
i had mode-old and at the same time i was sending single digits (test numbers) :)

but it still doesnt pass the block character problem. my log:


also i think it might be helpful if you saw my smsd.conf file:



of course, all the settings above are from a newbie

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
The "box like" character is a Ctrl-Z which is used to terminate the PDU. In your first post there has been a connection problem with a modem, and therefore smsd tried to send that termination character.

You are sending SMS to the number which is presented using national format. This causes the failure. Numbers should be presenter using international format. Try again with To: 2010....

It is also possible to define the format of a number using To_TOA header. Settings international_prefixes and national_prefixes are also available. If you use a global setting national_prefixes = 0, the selection of number format will be automatic. However, using the international format is always the best choice, because when you receive SMS or status report, there is number presented in this format. It is easier to handle messages when the format is always the same.

Member
Registered:
Jun 2010
Location: Egypt
Topic owner
keke
first of all i would like to thank you for your patience. seriously

next, i think i should explain what i want to do with smstools. i have set up a monitoring tool (zenoss) to send out sms alerts. however, the software we use is extremely old on old hardware and would like to very much migrate it from proprietary to open source software.
the program will not receive any sms plus all sms sent will only be to local numbers

anyways, i did as you said and put the national_prefixes = 0 in the global section. i restarted smsd. i sent 3 sms
the first with local number
the second with full international number
the third with the + sign as part of the international number

no luck on any of the 3 trials

i am adding the smsd.conf file after the changes:


Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
The + sign is not required and not recommended to use. The smsd will remove it., but if you use it and store sent messages, you have To: +2010... and the number is not similar than in received messages.

You got CMS 500 for your messages, right?

Have you tested the SIM you are using? Put it into your handset, and try to send a message. Also, with handset, check what is the number of Service Center (SMSC). You could try to define it in the modem settings, smsc = <number in international format>.

You have disabled the pre_init, why is that? It causes that there is "echo on", but usually it should be "off".

Member
Registered:
Jun 2010
Location: Egypt
Topic owner
hi keke
thanks for your very fast response

i do not want to use international format as my application doesnt have the mobile numbers recorded in international format.

yes i got CMS 500 errors

i will put the SMSC number in
pre_init - was taken from another forum post here for one of my earlier problems. i will remove it and try again

the sim works. it has been with me for years. i previously (about 2 years ago) used the vodafone's betavine software to send sms from it.

my conf after changes:


my log when i tried to send the sms:


Member
Registered:
Jun 2010
Location: Egypt
Topic owner
ah no sms sent out
neither in local format or international format

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
There was a bug causing that the setting national_prefixes did not work. :(

I had to publish a new version 3.1.10 which fixes this. Please download it and try once again.

The number of smsc is perhaps not correct, as it starts with two zeroes. In your country international number should start with "20". You could try to shorten the number.

Member
Registered:
Jun 2010
Location: Egypt
Topic owner
hi keke
i am impressed you wrote not one but TWO bug fixes especially for me. thanks.

however, the new version also does not work :(
i tried with "national_prefixes = 0" and without.

each time i sent 3 messages the number would be 002010..or 2010.. or 010..

the same error message showed up



thanks

Member
Registered:
Jun 2010
Location: Egypt
Topic owner
hi again

the order of the trial messages i sent were
010..
002010..
2010..

Member
Registered:
Jun 2010
Location: Egypt
Topic owner
it worked! :P

i'd overlooked your suggestion for smsc so i am posting my smsd.conf here for you and others:


thank you keke!

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Okay. And receiving works too? (if you set incoming = yes)

Member
Registered:
Jun 2010
Location: Egypt
Topic owner
i dont want to recieve

however out of the 3 numbers
002010.. works
2010.. works
010.. does NOT work

i need to have it accept and send in the last format coz all the numbers here (and applications - there are apparently 3 different applications) use the last format

Member
Registered:
Jun 2010
Location: Egypt
Topic owner
oh and i need to speed up processing of the messages

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
marafa wrote
i dont want to recieve

Some modems do not send messages if the memory is full. But if your modem works well, it's enough... ;)

marafa wrote
010.. does NOT work

Show the PDU (that 0011000B9102...).

marafa wrote
i need to have it accept and send in the last format coz all the numbers here (and applications - there are apparently 3 different applications) use the last format

Smsd can also change the format on the fly, but the PDU should be checked first.

Member
Registered:
Jun 2010
Location: Egypt
Topic owner
hello keke
thank you so much for all your help

i am sorry to say i do not understand what a PDU is nor how i can configure it to accept phone numbers with 010.. format

thanks

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Try the sending to 010... once more, and from the log show the similar lines than in your post #12.

I can then check the PDU, and if it's correct but the sending still fails, I provide an alternate resolution for you.

Member
Registered:
Jun 2010
Location: Egypt
Topic owner
the log when sending to 010...


and my _working_ smsd.conf



ps. i think you dint changed the version number for 3.1.10 from 3.1.9

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
marafa wrote
ps. i think you dint changed the version number for 3.1.10 from 3.1.9

Yes I did, but you are running 3.1.9 which has a bug in the reading of national_prefixes setting.

Move to the 3.1.10 and your message will be sent... ;)

Member
Registered:
Jun 2010
Location: Egypt
Topic owner
pls double check your end.

i went as far as downloading v3.1.10 again and recompiling it and overwriting my current smsd. it still says 3.1.9

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Ok, I double checked:

web5:/usr/local/src# wget smstools3.kekekasvi.com/packages/smstools3-3.1.10.tar.gz
web5:/usr/local/src# rm -rf smstools3
web5:/usr/local/src# tar -zxf smstools3-3.1.10.tar.gz
web5:/usr/local/src# cd smstools3/src
web5:/usr/local/src/smstools3/src# cat version.h
#ifndef VERSION_H
#define VERSION_H

#define smsd_version "3.1.10"

#endif

...

And then:

2010-06-20 15:46:41,2, smsd: Smsd v3.1.10 started.
2010-06-20 15:46:41,2, smsd: Running as root:root.


Your turn to double check? ;)

Member
Registered:
Jun 2010
Location: Egypt
Topic owner
sigh .. it wanted smsd to be in /usr/sbin and i was running around with /usr/local/bin and /usr/bin

it still doesnt send even thought it accepts the message. note .. on 3.1.9 if i manually create the file i get the same response


the file that i put in the outgoing directory


and again.. thank you very much for your patience

  This topic is locked

Page:  1  2  Next

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.