SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Sat May 25, 2024 10:58
SMSTools3 Community » Help and support Bottom

[fixed in 3.1.12] Only one modem is being used

  This topic is locked

Page:  1

Author Post
Member
Registered:
Jun 2010
Location: Kaunas, Lithuania
Hello,

I have two modems connected. And they are assigned to queue Q1. I send create files in outgoing directory with specified "Queue: Q1" but it seems that at the same time, only one modem is being used. Here is log and conf files.

http://62.212.213.138:8080/files/smsd.conf
http://62.212.213.138:8080/files/log.log

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
The log shows that both modems GSM10 and GSM11 are sending messages from Q1.

There are GSM20 and GSM21 also defined, but probably those processes have stopped because of the failure with opening a device. From the begin of a log you can see what was the failure.

Member
Registered:
Jun 2010
Location: Kaunas, Lithuania
Topic owner
From
2010-07-07 15:32:37,6, GSM11: Moved file /var/spool/sms/Q1/job_16_5UWBwI to /var/spool/sms/sent/job_16_5UWBwI
to
2010-07-07 15:34:10,6, GSM11: Moved file /var/spool/sms/Q1/job_16_GUflZa to /var/spool/sms/sent/job_16_GUflZa
All sms between are sent using GSM11.

From
2010-07-07 15:34:19,6, GSM10: Moved file /var/spool/sms/Q1/job_16_GVhip9 to /var/spool/sms/sent/job_16_GVhip9
to
2010-07-07 15:34:58,6, GSM10: Moved file /var/spool/sms/Q1/job_16_UDCt15 to /var/spool/sms/sent/job_16_UDCt15
There only GSM10 is being used.

What I want is that both modems would be working ate the same time.

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Ok, there is a problem with spooling. I try to release 3.1.12 within a next few days to fix this.

In the meanwhile, use the modem setting trust_spool = no in the [default] section. Also a global setting delaytime = 1 could be usefull.

Member
Registered:
Jun 2010
Location: Kaunas, Lithuania
Topic owner
Thanks, it helped.

  This topic is locked

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.