SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Sat May 25, 2024 12:08
SMSTools3 Community » Help and support Bottom

[answered] Software Hang

  This topic is locked

Page:  1

Author Post
Member
Registered:
Jul 2010
Location: Hong Kong
Operating system name and version: Win2003 Standard SP2
Version of smsd: 3.1.8
Smsd installed from: sources
Name and model of a modem / phone: SIEMENS TC35
Interface: USB

I cannot know why the smsd always hang.
The folder checked have a LOCK file stuck in the directory.



This is log of today. After the last line, all things stopped.
If I run "net stop smsd", the program cannot be terminated.
I need to kill the smsd.exe using task manager and run "net start smsd" then everything works fine.

Please advice what can I do to solve the problem. Thanks.


« Last edit by xpking on Thu Jul 08, 2010 15:00, 168 months ago. »
Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
I do not know what causes this problem. In this post, michel has the similar problem on Windows XP with USB connection.

Perhaps you could try to re-install drivers, or even whole Cygwin. It seems that the driver freezes, and smsd cannot do anything because the read() function does not return.

Member
Registered:
Jun 2010
Location: tx, United States of America
I run a complete USB setup and have also had hangs. Most of my hangs were cured by setting pre-init to no and lowering the baudrate to 19,200.

I still hang on occasion but it is the result of the flakiness in XP handling usb. If for some reason my modems decide to detach and reattach, smsd will hang without warning until it tries to write to the modem (log lvl 5 that is).

Make sure you have good power -use a dual usb power cable if you have to or use a powered hub.

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
finnman wrote
I run a complete USB setup and have also had hangs. Most of my hangs were cured by setting pre-init to no and lowering the baudrate to 19,200.

Maybe this is a hint. Disabling pre-init should not have an effect, as it is just a command which is sent to the modem right after OK answer is received for AT command. But because it has impact, perhaps slower communication is required. There is a setting available for some problematic modems: communication_delay. It defines minimum time in milliseconds between latest answer from modem and next command which will be sent to modem. Perhaps some value 100, 250 or even 500 could be tried, if it helps.

  This topic is locked

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.