SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Tue Jun 25, 2024 14:39
SMSTools3 Community » Help and support Bottom

[solved] SMS trouble : put_command expected (>)|(ERROR), timeout occurred

  This topic is locked

Page:  1

Author Post
Member
Registered:
May 2009
Hi,

About 1 out of 4 SMS messages I try to send get lost in the process. This seems to be caused by timeouts occurring. “put_command expected (>)|(ERROR), timeout occurred”
I use a rather slow Siemens MC35i so I’ve tried to set the read_timeout to 20 seconds but even that didn’t seem to solve the problem. I've also tried experimenting with different baud rates but that seemed to make it even worse. What could be causing this issue ?

This is a piece of the log file with the timeout :



« Last edit by keke on Mon May 18, 2009 10:29, 183 months ago. »
Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
What is the version of smsd you are using?

This kind of delay can happen if a modem is receiving message at the same time while trying to send. Also a weak signal can cause network errors and of course the GSM network itself can be slow. You could check the antenna and it's location. Put init2 = AT+CSQ to the modem setting, you then can see signal quality value in the log. In some cases even read_timeout = 60 or more is required.

Member
Registered:
May 2009
Topic owner
Thanks for the quick reply.

This is the config file :
devices = SiemensMC35i
outgoing = /var/spool/sms/outgoing
checked = /var/spool/sms/checked
failed = /var/spool/sms/failed
#incoming = /var/spool/sms/incoming
#report = /var/spool/sms/report
#sent = /var/spool/sms/sent
logfile = /var/log/smsd.log
loglevel = 7

[SiemensMC35i]
init = AT+CPMS="SM"
device = /dev/ttyS0
incoming = no
outgoing = yes
smsc = 0475161616
baudrate = 115200
rtscts = yes
read_timeout = 60
init2 = AT+CSQ

I use 3.1.5beta8. No incoming SMS messages are allowed. I have tried to increase the read_timeout to 60 seconds without improvement.

Here is a new piece of log.



What should indicate the singnal quality in the log. Also when I tail the log file it never seems to wait for 60 seconds for anything.


« Last edit by mrbob909 on Mon May 18, 2009 11:31, 183 months ago. »
Member
Registered:
May 2009
Topic owner
I have run the AT+CSQ command a few times with my PC connected to the SMS modem.
It returned values between 14,99 and 17,99.

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
CSQ 12 means that signal is not very strong. A value near to 20 or more is better. 99 means that Bit Error Rate is not measurable. Next version will explain values in the log.

I have to check your log more, but one question now: did you restart smsd after changing smsd.conf?

Member
Registered:
May 2009
Location: Italy
Hi Keke,
would be great to have Signal Level just in log level 5 or 6. This permit me to have just signal in realtime without write a lot of logs.

Thanks

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Next version has this change: if init2 is AT+CSQ (uppercase), signal quality is explained in log with loglevel 5 (log_notice).

Member
Registered:
May 2009
Topic owner
keke wrote
CSQ 12 means that signal is not very strong. A value near to 20 or more is better. 99 means that Bit Error Rate is not measurable. Next version will explain values in the log.

I have to check your log more, but one question now: did you restart smsd after changing smsd.conf?
Hi,
Yes, I did restart the daemon each time I made a config change. The CSQ value is stable around 17,99 so that should be OK.

It seems like smsd is just impatient and it sends too many commands too fast for my modem to handle. It should wait longer between each command because my sms modem just can't keep up.


« Last edit by mrbob909 on Tue May 19, 2009 07:57, 183 months ago. »
Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
I have to say that your log pieces look very strange. Something this kind can be seen if there is two smsd's running at the same time (which is illegal).

mrbob909 wrote
I use 3.1.5beta8.

Hopefully yes, but I think that you are using at least 3.1.2, probably 3.1.3 but not later than 3.1.5beta, the first beta (not beta8). Because 3.1.5beta has not been available for a long time, my guess is that you are using 3.1.3. Did I win? :)

You are using some Linux because your port is ttyS0, right? In Linux there is no good and standard way to lock serial ports and therefore it is possible that some other program uses the same port at the same time. Have you ensured that no any other program is using this port?

While testing smsd, it's easy to start, as an accident, more than one daemons at a time if not using init.d/sms3 script on every start. Because of this, there is a detection in later beta's and this causes that already running smsd quits.

Another important thing is that while smsd in running on background, it's illegal to use smsd -s for status monitoring on the foreground. This is because there will be two processes for each modem and strange errors will happen...

Have you checked / can you check that there surely is no more than one smsd running (one mainprocess and one modem process)?

Member
Registered:
May 2009
Topic owner
Hi,

I'm sorry about the confusion, I'm using 3.1.2. I'm just using the package, someone else maintains the server and he installed it for me. But you were right there were multiple smsd daemons running. They were all killed and the daemon was properly started.

First tests showed a good results so far.

Thanks

Member
Registered:
Jul 2009
Location: NCR, Philippines
Please help me,

Incoming is OK, but I cannot make SEND work.

I am using SAMSUNG SGH-e590

Here is my config



HERE is the LOG FILE



I am usng verion 3.1.3

Thanks
Dexter

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
You are using national destination number format. Use international format without the + sign.

Member
Registered:
Jul 2009
Location: NCR, Philippines
I already tried using
639224565051

63 is the international code for Philippines.

Hoping for your help

Thanks
Dexter

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Ok, next you could try to define smsc = <service center number in international format> in the modem section of smsd.conf. I assume that you have not yet tried this because there is a German number commented out. Correct number depends on the operator and it's not a phone number. And remember to restart smsd after change is done.

Member
Registered:
Jul 2009
Location: NCR, Philippines
Here is the log



I still cannot send the SMS.

Is SAMSUNG SGH-e590 ok to use? It have a SAMSUNG MODEM and a SERIAL port when connected to LINUX.

Thanks

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Strange :(

This device should work as it recognizes all necessary commands. You have used this SIM to send SMS using an ordinary phone interface and it worked?

Probably this is a communication failure as you have disabled handshaking. Please try with lower speed, like baudrate = 19200 and put handshaking on (rtscrt = yes or comment out the line).

Member
Registered:
Jul 2009
Location: NCR, Philippines
i setup as you said.

But still does not work. help!

Its my first time to setup an SMS gateway. I have not tried to use other devices as well.
Some of the devices mentioned are old, dont know if there are still cable for that?

Please help

Thanks
Dexter

HERE IS THE LOG



Member
Registered:
Jul 2009
Location: NCR, Philippines
Hi,

Thanks Keke for the help.
I manage to make it working but not for SAMSUNG SGH - e590

I used another phone

SAMSUNG SGH-e250i

Thanks again.
Dexter

  This topic is locked

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.