SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Thu May 23, 2024 02:42
SMSTools3 Community » Help and support Bottom

[solved] CMS ERROR: 38 (Network out of order) 2

  This topic is locked

Page:  1

Author Post
Member
Registered:
Jan 2010
Location: Manila, Philippines
Operating system name and version: Debian (ubuntu server 2.6.27-11-server)
Version of smsd: SMS Server Tools 3 (beta)
Smsd installed from: sources / package repository / from elsewhere...
Name and model of a modem / phone: Wavecom, philip, china modem
Interface: serial and USB

Hi! good day, i have SMS tools version 3 the beta version i was installed before and running perfectly but i have trouble this a few days one of my modem trouble with this error (CMS ERROR: 38 (Network out of order) this topic is ready posted here [solved] + CMS ERROR: 38 (Network out of order) i follow all setting and direction posted here but still no luck. :| hope someone help me thank you.

here is my partly setting on my config file.

devices =  1_Smart, 1_Sun, 1_Globe, 2_Smart, 3_Smart, 4_Smart, 2_Globe, 3_Globe
#devices = 0_GlobeRcv, 1_SmartRcv
#devices = 0_GlobeRcv

logfile = /var/log/smsd.log
#infofile = /var/run/smstools/smsd.working
#pidfile = /var/run/smstools/smsd.pid
outgoing = /var/spool/sms/outgoing
checked = /var/spool/sms/checked
failed = /var/spool/sms/failed
incoming = /var/spool/sms/incoming
sent = /var/spool/sms/sent
#stats = /var/log/smstools/smsd_stats
stats_interval = 3600
loglevel = 7
user = root
eventhandler = /var/spool/sms/script/event/handler
blacklist = /var/spool/sms/blacklist/number
autosplit = 3
keep_filename = no

[queues]
smart = /var/spool/sms/smart
globe = /var/spool/sms/globe
sun   = /var/spool/sms/sun
rcv   = /var/spool/sms/received
unli   = /var/spool/sms/unli

[provider]
smart = 63919, 63921, 63918, 63928, 63920, 63909, 63910, 63929, 63908, 63912, 63907,63908,63939,63912, 6399
globe = 63917, 63915, 63916, 63906, 63905, 63927, 63926, 63906, 63935, 63936, 63937, 63935
sun   = 63922, 63923, 63933, 63932
rcv   = 6301
unli  = s258, s8888, s247, s222, s214


[2_Globe]
device = /dev/ttyACM3
incoming = Yes
baudrate = 460800
queues = globe
smsc = 639170000130
mode = new
init = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
 
'smsdconf' Syntax Highlight powered by GeSHi


and here is my partly log file.



I am from Philippines and sorry for my english.

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
I assume that the destination number is correct, which means that there probably has been a service break in the GSM network. Can you send to other numbers which begins with "63935"?

Another thing: you are using an init string which puts "echo ON". Usually this should not be done. Change "E1" to "E0" in the init string, or remove "E1" completely. It is also possible that you do not need any init string with a modem based on Wavecom chip.

Member
Registered:
Jan 2010
Location: Manila, Philippines
Topic owner
keke wrote
Can you send to other numbers which begins with "63935"?

Yes, but recently error appear i don't know what happen, i think there is problem with my modem? putting SMSC setting on my sms.conf but nothings happen, i check my Outgoing file but the SMSC is still blank. :|

Check this one



Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
If you can send to other numbers, there is no problem with a modem.

When did you do the latest test for sending to 639351979986, and are you still unable to send to that number, at the same time when sending to other numbers work?

In the PDU there is no SMSC field, because by default smsd does not include SMSC in the PDU. Version 3.1.12 has option for this, but usually SMSC is changed using CSCA command, like your system does:



Why do you think that SMSC does matter, as the sending has previously worked well, assuming that you have not changed any settings when the problem occurred?

Member
Registered:
Jan 2010
Location: Manila, Philippines
Topic owner
Quote
In the PDU there is no SMSC field, because by default smsd does not include SMSC in the PDU. Version 3.1.12 has option for this, but usually SMSC is changed using CSCA command, like your system does:

But there is no error regarding this command right? look at this. The simcard replied okay.



Quote
Why do you think that SMSC does matter, as the sending has previously worked well, assuming that you have not changed any settings when the problem occurred?

i don't have SMSC setting when the error occurred then im putting this command becuase this is the solution i got from http://smstools3.kekekasvi.com/topic.php?id=159 but still no luck.


« Last edit by bhebsquines on Thu Oct 14, 2010 15:30, 165 months ago. »
Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
bhebsquines wrote
keke wrote
In the PDU there is no SMSC field, because by default smsd does not include SMSC in the PDU. Version 3.1.12 has option for this, but usually SMSC is changed using CSCA command, like your system does:

But there is no error regarding this command right? look at this. The simcard replied okay.




Right, no error... But the point was that in your dump of PDU there is no SMSC number because it is not meant to be there. If the number of SMSC is changed, it is changed using CSCA.

bhebsquines wrote
keke wrote
Why do you think that SMSC does matter, as the sending has previously worked well, assuming that you have not changed any settings when the problem occurred?

i don't have SMSC setting when the error occurred then im putting this command becuase this is the solution i got from http://smstools3.kekekasvi.com/topic.php?id=159 but still no luck.

That solution was different. The member was never before sent SMS, and got that CMS 38 as a first error. Because there are no many settings in smsd which may cause this, I recommended to try if setting the SMSC helps. It did not help. Next, from the log I saw that national number format for recipient was used. This was causing the CMS 38 in that case.

In your case, as you did not use the SMSC setting before the problem occurred, the SMSC is not the reason (unless the number is changed by the operator, but it is very unusual, and causes that any messages will fail).

After the error, you was able to send SMS to other numbers which begins with "63935". This means that your SIM, modem, etc. are working properly.

bhebsquines wrote
but recently error appear

Meaning what? When sending to 639351979986 or when sending to any number which begins with "63935"?

keke wrote
When did you do the latest test for sending to 639351979986, and are you still unable to send to that number, at the same time when sending to other numbers work?

How is this? If you now send SMS to 639351979986, and to other number, do they fail both, none, or just ..9986?

If, after the first error, you have sent SMS successfully to ..9986, there has been a service break or failure in the GSM network.

Member
Registered:
Jan 2010
Location: Manila, Philippines
Topic owner
Quote
How is this? If you now send SMS to 639351979986, and to other number, do they fail both, none, or just ..9986?

If, after the first error, you have sent SMS successfully to ..9986, there has been a service break or failure in the GSM network.

No, all of numbers listed in queues for globe are failed.


but when i insert my simcard to my regular Cellphone i can send message.

look at my another modem. This for Smart modem setting.





Same setting, same file, same server but everything alright then i compared na two file this is the result.

File for GLObe


File for Smart


Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
bhebsquines wrote
Quote
How is this? If you now send SMS to 639351979986, and to other number, do they fail both, none, or just ..9986?

If, after the first error, you have sent SMS successfully to ..9986, there has been a service break or failure in the GSM network.

No, all of numbers listed in queues for globe are failed.



I was assuming that sending to some numbers works (post #3), but now the issue is that sending to any numbers does not work, at least with a modem 1_Globe...

You have two another modems serving the globe queue. Do they work properly?

If they work without problems, you could try to swap devices, and check if the problem moves with the SIM and how another SIM works in the modem which originally was used with 1_Globe.

With swapping you can check if your modem is broken.

bhebsquines wrote
but when i insert my simcard to my regular Cellphone i can send message.

This means that the SIM itself is not broken and contract with operator is valid.

With your handset you could check what is the SMSC setting shown in the phone. I assume that it's the same what you have tried to use with smsd, but it should still be checked.

bhebsquines wrote
look at my another modem. This for Smart modem setting.






It's Sun, not Smart, but anyway, it works properly.

bhebsquines wrote
Same setting, same file, same server but everything alright then i compared na two file this is the result.

File for GLObe


File for Smart



Sorry, I did not understand... Sending with Sun worked, and sending with Globe worked too? Was that sent using 1_Globe, or with another modem which serves the globe queue?

Member
Registered:
Jan 2010
Location: Manila, Philippines
Topic owner
Quote
was assuming that sending to some numbers works (post #3), but now the issue is that sending to any numbers does not work, at least with a modem 1_Globe...

You have two another modems serving the globe queue. Do they work properly?

If they work without problems, you could try to swap devices, and check if the problem moves with the SIM and how another SIM works in the modem which originally was used with 1_Globe.

With swapping you can check if your modem is broken.

Hi! keke thank you for your time, Sorry for that, i have 4 modem for Smart, 3 Modem for Globe and 1 Modem for Sun.



All modem for globe are same problem while the Sun and Smart are works properly.


Quote
It's Sun, not Smart, but anyway, it works properly.

Sorry it's Sun.

Quote
With your handset you could check what is the SMSC setting shown in the phone. I assume that it's the same what you have tried to use with smsd, but it should still be checked.

Yes i got my SMSC number from my personal mobile.

Quote
Sorry, I did not understand... Sending with Sun worked, and sending with Globe worked too? Was that sent using 1_Globe, or with another modem which serves the globe queue?

what i mean is i am comparing the two file the Sent file of SUN and the Failed File of GLOBE they are the same. i changed my Smart Simcard to globe modem then vise versa but globe still have problem and Smart work fine. anyways i think i need to buy new simcard. :| :|

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
bhebsquines wrote
keke wrote
You have two another modems serving the globe queue. Do they work properly?

All modem for globe are same problem while the Sun and Smart are works properly.

Thank's for telling that. I was in the believe that only with 1_Globe you have the problem...

bhebsquines wrote
keke wrote
With your handset you could check what is the SMSC setting shown in the phone. I assume that it's the same what you have tried to use with smsd, but it should still be checked.

Yes i got my SMSC number from my personal mobile.

Ok, then it surely is correct and still valid. As it is a default number of SMSC, you do not need to set it in the smsd.conf

bhebsquines wrote
keke wrote
Sorry, I did not understand... Sending with Sun worked, and sending with Globe worked too? Was that sent using 1_Globe, or with another modem which serves the globe queue?

what i mean is i am comparing the two file the Sent file of SUN and the Failed File of GLOBE they are the same.

Too complicated... :( Files does not look like the same, but anyways...

bhebsquines wrote
i changed my Smart Simcard to globe modem then vise versa but globe still have problem and Smart work fine. anyways i think i need to buy new simcard. :| :|

Okay, your modems are not broken and Globe SIM cards work well when using in handset. You could check if you can receive messages with Globe SIM cards in modems, but probably this will not tell us anything useful which will solve the problem.

When the problem started, did it start at the same time with all Globe SIM cards?

Do you have any other SIM for Globe, in addition to those three which was used in modems? For example if your personal number in handset uses Globe, you could try that SIM in some modem.

This issue is starting to sound like Globe is detecting your devices, and prevents usage for sending when a device is modem. If you are going to buy new SIM, you could ask from Globe if it can be used with a modem, or is it prevented.

Member
Registered:
Jan 2010
Location: Manila, Philippines
Topic owner
Hi! keke thank you for your help and apologized for late reply i just observed my SMS and leave my SMS system in a few days without changing anything and now everything goes fine. I think my network operator is the problem because the error arise every time i send thousand messages, i think there is quotation of the network gateway. :roll:




« Last edit by bhebsquines on Sat Oct 23, 2010 03:30, 165 months ago. »

  This topic is locked

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.