SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Sat May 25, 2024 10:26
SMSTools3 Community » Help and support Bottom

[solved] smsd hangs at AT, but minicom works

  This topic is locked

Page:  1

Author Post
Member
Registered:
Nov 2010
Location: Lohja, Finland
Operating system name and version: Debian Linux 5.0.6
Version of smsd: 3.1.14
Smsd installed from: sources
Name and model of a modem / phone: WAVECOM Fastrack Xtend GPRS
Interface: USB

This Wavecom seemed to work correctly over a serial link (115200 with hardware flow control), until a longer message (>100 chars) was sent. Any long string would hang the device completely.

I suspected the serial cable could be faulty and switched to USB. Minicom works happily with the device that sits at /dev/ttyACM0 configured to 115200 baud. However, smsd refuses to talk to this device completely.

Here's my smsd.conf with non-relevant lines commented out for testing:


Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
It sounds like the device driver hangs for some reason.

With Minicom, did you try to send SMS containing more than 100 characters in PDU mode? If you did not, you could create a PDU using PDU Converter and then try to send it. Terminate the PDU with Ctrl-Z character.

In the smsd.conf you could try a modem setting send_handshake_select = no. With this setting different method is used to send data to the modem. I'm not sure if this helps, because "select" method should work with any interface.

Member
Registered:
Nov 2010
Location: Lohja, Finland
Topic owner
send_handshake_select worked perfectly, thanks for the quick reply!

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Good, but strange...

I run smsd on Debian 5.0.6, uname -a:
Linux macmini 2.6.26-2-powerpc #1 Tue Aug 31 09:21:51 UTC 2010 ppc GNU/Linux

"Select" method works properly, and is used in some other softwares too.

Just for curiosity, did you send only shorts strings to the modem using Minicom?

Member
Registered:
Nov 2010
Location: Lohja, Finland
Topic owner
I never tried long strings in minicom, so this detail is unclear. Typical AT commands worked instantly though.

Before setting send_handshake_select = no, I noticed that smsd always hung after sending its first AT, but it did continue when something else was requested of it, like sending a message would make it notice the AT OK and it would then send the init line and again stop there until nudged...

Does it matter that it's running on AMD64?

$ uname -a
Linux marissa 2.6.26-2-amd64 #1 SMP Mon Jun 21 07:30:07 UTC 2010 x86_64 GNU/Linux

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
cyanshade wrote
Before setting send_handshake_select = no, I noticed that smsd always hung after sending its first AT, but it did continue when something else was requested of it, like sending a message would make it notice the AT OK and it would then send the init line and again stop there until nudged...

If you have some older smsd.log available which show what exactly has happened, a piece of it would be interesting to see here. Some modems do not answer to the first AT command, but that problem is permanent, the answer is lost forever and next commands work without problems.

cyanshade wrote
Does it matter that it's running on AMD64?

$ uname -a
Linux marissa 2.6.26-2-amd64 #1 SMP Mon Jun 21 07:30:07 UTC 2010 x86_64 GNU/Linux

It should not matter, but you never know...

Version 3.1.9 was tested on AMD64 (single processor machine) which was running Ubuntu 10.04 64bit, and there was no this kind of a problem.

  This topic is locked

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.