SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Sun Feb 28, 2021 21:23
SMSTools3 Community » Help and support Bottom

[solved] Cant send sms in national format

  This topic is locked

Page:  1

Author Post
Member
Registered:
Jul 2011
Location: Germany
Operating system name and version: Suse 11.3
Version of smsd: 3.1.5
Smsd installed from: sources
Name and model of a modem / phone: 2x Hardware modem
Interface: serial and usb2serial adapter

Hi,
thank you for the great smstools.
I'm from germany. We only send sms to germany and i try to send the sms in national format.
If I send the message in national format I allways get the following error


For example the phone number is 0174 ??????
If I send with 49174 ?????? it works.
I try to set


in /etc/smsd.conf without success
I also try to set To_TOA in my email2sms script


It does not work too.

What is wrong? Do I make a mistake?

Thank You for help.

Greatings Martin

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Set loglevel to 7. Send one SMS and from the log take the PDU string (long string of digits). With this tool verify that the TOA is "national". Assuming that it was correctly "national", try to use a header "To_TOA: unknown". If it does not work, in your country national numbers cannot be used. In that case you have to use international format, or create a checkhandler which converts numbers from national format to international format.

Member
Registered:
Jul 2011
Location: Germany
Topic owner
Thank You, it is working.
I set "To_TOA: unknown". But why do I must set unknown and not "national"?

But now it does not work to send a sms with 49174. Is it possible to use both for my country?

Thank You for help.

Martin


« Last edit by Martin on Mon Jul 11, 2011 06:16, 117 months ago. »
Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Martin wrote
I set "To_TOA: unknown". But why do I must set unknown and not "national"?

There are differences in countries and service centers.

I will insert a setting national_toa_unknown = yes/no to the next version.

In the meanwhile, as you have installed smsd from sources, you could consider to modify the code:

In the pdu.c search "nf = NF_NATIONAL;". It's there three times. Change the first two lines to nf = NF_UNKNOWN;. Do not change the last one which is nf = NF_NATIONAL; // 1010 0001. Save, recompile and replace executable. After this national_prefixes = 0 should work.

Martin wrote
But now it does not work to send a sms with 49174. Is it possible to use both for my country?

Sending to number which starts with country code should work with international format which is a default. In this case do not set To_TOA.

When you receive messages, the format of number usually is international. And if you later will receive delivery reports, the format usually is international too. In this case international format could be used when sending messages, because handling of delivery reports is much easier when the format is the same.

  This topic is locked

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.