SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Sun Mar 07, 2021 10:59
SMSTools3 Community » Help and support Bottom

[solved] weared characters in sms message

  This topic is locked

Page:  1

Author Post
Member
Registered:
Aug 2011
Location: Netherlands
Operating system name and version: Ubuntu 10.04
Version of smsd: 3.1.6
Smsd installed from: ?
Name and model of a modem / phone: Sierra Wavecom Airlink
Interface: USB

When I use normal characters in my sms message, it is received and displayed correctly. However when I use a special character, the message length is reduced and I get question marks between the characters, like:

P�V� �a�d�m�i�n� �-T�e�s�t� �m�e�s�s�a�g�e

In this message I used a pipe "|" character (from a HTC phone). This message sent to another phone would not have given a problem.

Is this a problem of the encoding by the sending phone or should I modify the settings in smsd.conf? No idea how...
Thanks
Insomniux

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
When you type characters outside the GSM alphabet, phone automatically switches alphabet to Unicode. By default smsd does not decode this text. It is stored as it was received, and in the message file there is a header Alphabet which tells the encoding. Put the setting decode_unicode_text = yes to the global part or modem settings in smsd.conf, and your message should be shown properly (decoding in that version works with latin character sets).


Hidden private text.



Member
Registered:
Aug 2011
Location: Netherlands
Topic owner
Thanks keke, this solved the problem :D !
Cheers,
Insomniux

  This topic is locked

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.