SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Sun Mar 07, 2021 12:26
SMSTools3 Community » Help and support Bottom

Tango-55 won't send SMS anymore

Login and Post Reply

Page:  1

Author Post
Member
Registered:
Aug 2012
Location: Germany
Operating system name and version: CentOS 5.8
Version of smsd: 3.1.14
Smsd installed from: sources
Name and model of a modem / phone: Falcom Tango 55
Interface: serial

Hi

we have Problems sending SMS. For years it worked fine. But now smsd failed to send Messsages.

The log says, that the SMS was sent successfully, but the SMS did not receive.
We checked the SIM with the Provider. It's OK.


Logfile :

2012-08-15 15:47:37,5, GSM1: Waiting for messages to send...
2012-08-15 15:48:35,5, smsd: Moved file /var/spool/sms/outgoing/send_QN3926 to /var/spool/sms/checked
2012-08-15 15:48:36,6, GSM1: I have to send 1 short message for /var/spool/sms/checked/send_QN3926
2012-08-15 15:48:36,6, GSM1: Sending SMS from to 49xxxxxxxxxxx
2012-08-15 15:48:36,6, GSM1: Checking if modem is ready
2012-08-15 15:48:37,7, GSM1: -> AT
2012-08-15 15:48:37,7, GSM1: Command is sent, waiting for the answer
2012-08-15 15:48:37,7, GSM1: <- OK
2012-08-15 15:48:37,6, GSM1: Pre-initializing modem
2012-08-15 15:48:37,7, GSM1: -> ATE0+CMEE=1;+CREG=2
2012-08-15 15:48:37,7, GSM1: Command is sent, waiting for the answer
2012-08-15 15:48:37,7, GSM1: <- OK
2012-08-15 15:48:37,6, GSM1: Checking if modem needs PIN
2012-08-15 15:48:38,7, GSM1: -> AT+CPIN?
2012-08-15 15:48:38,7, GSM1: Command is sent, waiting for the answer
2012-08-15 15:48:38,7, GSM1: <- +CPIN: READY OK
2012-08-15 15:48:38,7, GSM1: -> AT+CSQ
2012-08-15 15:48:38,7, GSM1: Command is sent, waiting for the answer
2012-08-15 15:48:38,7, GSM1: <- +CSQ: 25,99 OK
2012-08-15 15:48:38,6, GSM1: Signal Strength Indicator: (25,99) -63 dBm (Excellent), Bit Error Rate: not known or not detectable
2012-08-15 15:48:38,6, GSM1: Checking if Modem is registered to the network
2012-08-15 15:48:39,7, GSM1: -> AT+CREG?
2012-08-15 15:48:39,7, GSM1: Command is sent, waiting for the answer
2012-08-15 15:48:39,7, GSM1: <- +CREG: 2,1 OK
2012-08-15 15:48:39,6, GSM1: Modem is registered to the network
2012-08-15 15:48:39,6, GSM1: Selecting PDU mode
2012-08-15 15:48:39,7, GSM1: -> AT+CMGF=0
2012-08-15 15:48:39,7, GSM1: Command is sent, waiting for the answer
2012-08-15 15:48:39,7, GSM1: <- OK
2012-08-15 15:48:39,6, GSM1: Changing SMSC
2012-08-15 15:48:40,7, GSM1: -> AT+CSCA="+4917XXXXXXXXX"
2012-08-15 15:48:40,7, GSM1: Command is sent, waiting for the answer
2012-08-15 15:48:40,7, GSM1: <- OK
2012-08-15 15:48:40,7, GSM1: -> AT+CMGS=29
2012-08-15 15:48:40,7, GSM1: Command is sent, waiting for the answer
2012-08-15 15:48:41,7, GSM1: <- >
2012-08-15 15:48:41,7, GSM1: -> 0011000C919471252207130000FF11D4F29C0EB2BFDB206AD87D7E836A35
2012-08-15 15:48:41,7, GSM1: Command is sent, waiting for the answer
2012-08-15 15:48:41,7, GSM1: <- OK
2012-08-15 15:48:41,5, GSM1: SMS sent, Message_id: , To: 4917XXXXXXXXX, sending time 5 sec.
2012-08-15 15:48:41,6, GSM1: Deleted file /var/spool/sms/checked/send_QN3926


Any hints ?

thx
Gunnar

Member
Registered:
Aug 2012
Location: Germany
Topic owner
Update:

I tried the Modem on another System, and it works fine.

One difference was that I've got a message ID from the modem. The ID is missing in the log above.

The Problem occurs after upgrading from CentOS 5.7 to 5.8

Gunnar

Member
Registered:
Aug 2012
Location: Germany
Topic owner
It's solved:

there was also a serial console running on /dev/ttyS0 !
After stopping it everything was fine

Gunnar

Login and Post Reply

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.