SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Sun Feb 28, 2021 21:32
SMSTools3 Community » Help and support Bottom

[solved] ZTE K3570-Z SMS receive problem

  This topic is locked

Page:  1

Author Post
Member
Registered:
Mar 2011
Location: Budapest, Hungary
Operating system name and version: Ubuntu Linux 10.10
Version of smsd: 3.1.14
Smsd installed from: sources
Name and model of a modem / phone: ZTE K3570-Z (Vodafone-HU)
Interface: USB

Hello,

I've just installed this usb modem to an ubuntu machine. I can send sms by the sendsms command but cannot receive them. Sms's are received only starting the original Vodafone software.

Is it some compatibility issue, or some misconfiguration? Thank you for your answer.

My smsd.conf:



/var/log/smsd.log:



Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Currently both memories SM and ME are empty:
Quote
2011-03-19 11:05:29,7, GSM1: <- +CPMS: "SM",0,50,"SM",0,50,"ME",0,100 OK

Try to send a new SMS to the modem, and show that line.

Member
Registered:
Mar 2011
Location: Budapest, Hungary
Topic owner
keke wrote
Currently both memories SM and ME are empty:
Quote
2011-03-19 11:05:29,7, GSM1: <- +CPMS: "SM",0,50,"SM",0,50,"ME",0,100 OK

Try to send a new SMS to the modem, and show that line.

Oh yes I've found this:



As I understand well this answer, that means the incoming sms is in the internal memory of the stick which is not accessible via serial.

And this section also says:

Quote
AT+CPMS="SM","SM","SM"


But how can I set this command up in the smsd?

Thank you.

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Try with a modem setting:

init = AT+CPMS="ME","ME","ME"

Member
Registered:
Mar 2011
Location: Budapest, Hungary
Topic owner
keke wrote
Try with a modem setting:

init = AT+CPMS="ME","ME","ME"

I've configured it and sent a test sms. Right after then the log says:



But right after:



Thank you once again...

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
memory_start = 0

Member
Registered:
Mar 2011
Location: Budapest, Hungary
Topic owner
keke wrote
memory_start = 0

And yes, that's working. Thank you for your support. I'm going to click the donate button right now. :-)

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Thanks and cheers! 8)

Later you might want to receive delivery reports for sent messages, I assume. To get that working, some additional information is required. Do you have a manual of AT commands for this device?

You could also set the modem setting report_device_details = yes, and show those details from the log.

Member
Registered:
Mar 2011
Location: Budapest, Hungary
Topic owner
keke wrote
Thanks and cheers! 8)

Later you might want to receive delivery reports for sent messages, I assume. To get that working, some additional information is required. Do you have a manual of AT commands for this device?

You could also set the modem setting report_device_details = yes, and show those details from the log.

Unfortunately I have only the manual packaged into the box which is for beginners who don't know what AT commads are. :-)

Device report says:



Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
I have some manuals for ZTE, but not for that exact model.

Anyways, your device seems to support a modem setting check_memory_method = 2, which is better than default method. You could try to use it.

There is "SR" memory available, but settings for CNMI are not clear. You could try to send SMS with a header "Report: yes". If after few minutes no report is received, try to use dual-memory handler:

primary_memory = ME
secondary_memory = SR


But if you do not need status reports, just ignore this feature.

Member
Registered:
Mar 2011
Location: Budapest, Hungary
Topic owner
keke wrote
I have some manuals for ZTE, but not for that exact model.

Anyways, your device seems to support a modem setting check_memory_method = 2, which is better than default method. You could try to use it.

There is "SR" memory available, but settings for CNMI are not clear. You could try to send SMS with a header "Report: yes". If after few minutes no report is received, try to use dual-memory handler:

primary_memory = ME
secondary_memory = SR


But if you do not need status reports, just ignore this feature.

I gave it a try with Report: yes and I got the sms. But instead of receiving the report I got the same "loop" as earlier:



But after setting primary and secondary memory, the report arrived successfully:



THANKS again.

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
It seems that there is a bug in the modem's firmware. It says 1 for ME, even when it's empty. But as the report now works, everything is fine.

You could still try method 2 for checking, because if it works as expected, it's much better. Default method gets the count of messages, but not indexes. When receiving more messages continuously, this may cause delays.

In any case, thanks for choosing this software 8) .

Member
Registered:
Mar 2011
Location: Budapest, Hungary
Topic owner
keke wrote
In any case, thanks for choosing this software 8) .

And thank you for writing this software. :-)

  This topic is locked

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.