SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Mon Mar 01, 2021 06:22
SMSTools3 Community » Help and support Bottom

[solved] can receive but not send messages

  This topic is locked

Page:  1

Author Post
Member
Registered:
May 2011
Location: germany, Germany
Operating system name and version: SLES 9
Version of smsd: 3.1.14
Smsd installed from: sources
Name and model of a modem / phone: SE W800i
Interface: serial/usb: /dev/ttyACM1

I can receive sms:



but i cant send, maybe because no ctrl-z is sent after the pdu - how can i have sent an ctrl-z after the pdu?



my config:
devices = GSM1
outgoing = /var/spool/sms/outgoing
checked = /var/spool/sms/checked
incoming = /var/spool/sms/incoming
loglevel = 7
#alarmhandler = /usr/local/bin/alarmevent
alarmlevel = 4
delaytime = 20
errorsleeptime = 30
blocktime = 3600
receive_before_send = no
# autosplit 0=no 1=yes 2=with text numbers 3=concatenated
autosplit = 3

[queues]
OTHER = /var/spool/sms/OTHER

[provider]
OTHER = 0,1,2,3,4,5,6,7,8,9

[GSM1]
init =  AT+CPMS="ME"
device = /dev/ttyACM1
incoming = yes
queues = OTHER
mode = new
baudrate = 19200
rtscts = yes
cs_convert = no
report = no
memory_start = 1
#message_count_clear = 60
verify_pdu=yes
 
 
'smsdconf' Syntax Highlight powered by GeSHi


Any idea?

Thanks for your help

chris

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
The sending fails, because the number is presented in national format. Change it to 49151xxxx.

There are settings available to handle number formats, but in usual cases international format is the best choice. See SMS file format, "To_TOA" and "Using Type Of Address selection".

Ctrl-Z is sent after the PDU, but your log (editor) just does not show it.

You have disabled cs_convert for some reason. When it is disabled, outgoing messages should be written using GSM alphabet instead of latin1, and incoming messages will be in GSM alphabet too. Is this what you really have meant?

Member
Registered:
May 2011
Location: germany, Germany
Topic owner
hello ke ke,

thank you very much for the fast answer

i tried 49151.... but unfortunately same result :-(



cs_convert was changed in hope to help - i tired many things, but did never succeed in sending.

now i have set cs_convert to yes again.

my first idea was an incomplete init string - an tried also there several options - without success...

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Have you verified this SIM in your handset? I assume that sending with it works. You could then check what is the number of Service Center (SMSC). Add a modem setting: smsc = <number in international format without the + sign>. Restart smsd and try once again.

Member
Registered:
May 2011
Location: germany, Germany
Topic owner
Helo keke

that was in deed the problem.
an wrong service-center.

i put in the correct one and it worked fine!

thx!

Great tool!

  This topic is locked

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.