SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Tue Mar 02, 2021 16:12
SMSTools3 Community » Help and support Bottom

When i send custome notifications from nagios it gives error like

Login and Post Reply

Page:  1

Author Post
Member
Registered:
Dec 2011
Location: HYDERABAD, India
Dear all,

I configured smstool to send sms alerts from nagios in Redhat Linux nagios 5.0.

But when i sent message using commond like
#sendsms +91xxxxxxxxxx "test message" - i am getting.

When i send custome notifications from nagios it gives error like

GSM1: Trying to get stored message 10
2011-12-11 02:56:50,7, GSM1: -> AT+CMGR=10
2011-12-11 02:56:50,7, GSM1: Command is sent, waiting for the answer
2011-12-11 02:56:51,7, GSM1: <- AT+CMGR=10
ERROR


I used NOKIA MOBILE MODEL 5130 C .


Please help me in resolving he issue.
Thanx.

Member
Registered:
Jun 2009
Location: Russian Federation
please put here your smsd.conf and whole smd.log
currently smsd fails to check incoming sms from your phone.

Member
Registered:
Dec 2011
Location: HYDERABAD, India
Topic owner
Here my smsd.conf file

# Example smsd.conf. Read the manual for a description

devices = GSM1
logfile = /var/log/smsd.log
loglevel = 7

[GSM1]
device = /dev/ttyACM0
incoming = yes
#pin = 1111


************************************************
Here smsd.log file
2011-12-11 02:50:01,6, GSM1: Modem handler 0 has started.
2011-12-11 02:50:01,6, smsd: outgoing file checker has started.
2011-12-11 02:50:01,6, GSM1: Checking device for incoming SMS
2011-12-11 02:50:01,6, GSM1: Checking if modem is ready
2011-12-11 02:50:01,7, GSM1: -> AT
2011-12-11 02:50:01,7, GSM1: Command is sent, waiting for the answer
2011-12-11 02:50:01,7, GSM1: <- AT
OK
2011-12-11 02:50:01,6, GSM1: Checking if Modem is registered to the network
2011-12-11 02:50:01,7, GSM1: -> AT+CREG?
2011-12-11 02:50:01,7, GSM1: Command is sent, waiting for the answer
2011-12-11 02:50:01,7, GSM1: <- AT+CREG?
+CREG: 0,1
OK
2011-12-11 02:50:01,6, GSM1: Modem is registered to the network
2011-12-11 02:50:01,6, GSM1: Selecting PDU mode
2011-12-11 02:50:01,7, GSM1: -> AT+CMGF=0
2011-12-11 02:50:01,7, GSM1: Command is sent, waiting for the answer
2011-12-11 02:50:02,7, GSM1: <- AT+CMGF=0
OK
2011-12-11 02:50:02,6, GSM1: Checking memory size
2011-12-11 02:50:02,7, GSM1: -> AT+CPMS?
2011-12-11 02:50:02,7, GSM1: Command is sent, waiting for the answer
2011-12-11 02:50:02,7, GSM1: <- AT+CPMS?
+CPMS: ,,,,,,,,
OK
2011-12-11 02:50:02,6, GSM1: Used memory is 1 of 10
2011-12-11 02:50:02,6, GSM1: Trying to get stored message 1
2011-12-11 02:50:02,7, GSM1: -> AT+CMGR=1
2011-12-11 02:50:02,7, GSM1: Command is sent, waiting for the answer
2011-12-11 02:50:02,7, GSM1: <- AT+CMGR=1
ERROR
2011-12-11 02:50:02,6, GSM1: Trying to get stored message 2
2011-12-11 02:50:02,7, GSM1: -> AT+CMGR=2
2011-12-11 02:50:02,7, GSM1: Command is sent, waiting for the answer
2011-12-11 02:50:03,7, GSM1: <- AT+CMGR=2
ERROR
2011-12-11 02:50:03,6, GSM1: Trying to get stored message 3
2011-12-11 02:50:03,7, GSM1: -> AT+CMGR=3
2011-12-11 02:50:03,7, GSM1: Command is sent, waiting for the answer
2011-12-11 02:50:03,7, GSM1: <- AT+CMGR=3
ERROR
2011-12-11 02:50:03,6, GSM1: Trying to get stored message 4
2011-12-11 02:50:03,7, GSM1: -> AT+CMGR=4
2011-12-11 02:50:03,7, GSM1: Command is sent, waiting for the answer
2011-12-11 02:50:03,7, GSM1: <- AT+CMGR=4
ERROR
2011-12-11 02:50:03,6, GSM1: Trying to get stored message 5
2011-12-11 02:50:03,7, GSM1: -> AT+CMGR=5
2011-12-11 02:50:03,7, GSM1: Command is sent, waiting for the answer
2011-12-11 02:50:04,7, GSM1: <- AT+CMGR=5
ERROR
2011-12-11 02:50:04,6, GSM1: Trying to get stored message 6
2011-12-11 02:50:04,7, GSM1: -> AT+CMGR=6
2011-12-11 02:50:04,7, GSM1: Command is sent, waiting for the answer
2011-12-11 02:50:04,7, GSM1: <- AT+CMGR=6
ERROR
2011-12-11 02:50:04,6, GSM1: Trying to get stored message 7
2011-12-11 02:50:04,7, GSM1: -> AT+CMGR=7
2011-12-11 02:50:04,7, GSM1: Command is sent, waiting for the answer
2011-12-11 02:50:04,7, GSM1: <- AT+CMGR=7
ERROR
2011-12-11 02:50:04,6, GSM1: Trying to get stored message 8
2011-12-11 02:50:04,7, GSM1: -> AT+CMGR=8
2011-12-11 02:50:04,7, GSM1: Command is sent, waiting for the answer
2011-12-11 02:50:05,7, GSM1: <- AT+CMGR=8
ERROR
2011-12-11 02:50:05,6, GSM1: Trying to get stored message 9
2011-12-11 02:50:05,7, GSM1: -> AT+CMGR=9
2011-12-11 02:50:05,7, GSM1: Command is sent, waiting for the answer
2011-12-11 02:50:05,7, GSM1: <- AT+CMGR=9
ERROR
2011-12-11 02:50:05,6, GSM1: Trying to get stored message 10
2011-12-11 02:50:05,7, GSM1: -> AT+CMGR=10
2011-12-11 02:50:05,7, GSM1: Command is sent, waiting for the answer
2011-12-11 02:50:05,7, GSM1: <- AT+CMGR=10
ERROR
2011-12-11 02:50:05,6, GSM1: No SMS received
2011-12-11 02:50:15,6, GSM1: Checking device for incoming SMS
2011-12-11 02:50:15,6, GSM1: Checking if modem is ready
2011-12-11 02:50:15,7, GSM1: -> AT
2011-12-11 02:50:15,7, GSM1: Command is sent, waiting for the answer
2011-12-11 02:50:16,7, GSM1: <- AT
OK
2011-12-11 02:50:16,6, GSM1: Checking if Modem is registered to the network
2011-12-11 02:50:16,7, GSM1: -> AT+CREG?
2011-12-11 02:50:16,7, GSM1: Command is sent, waiting for the answer
2011-12-11 02:50:16,7, GSM1: <- AT+CREG?
+CREG: 0,1
OK
2011-12-11 02:50:16,6, GSM1: Modem is registered to the network
2011-12-11 02:50:16,6, GSM1: Selecting PDU mode
2011-12-11 02:50:16,7, GSM1: -> AT+CMGF=0
2011-12-11 02:50:16,7, GSM1: Command is sent, waiting for the answer
2011-12-11 02:50:16,7, GSM1: <- AT+CMGF=0
OK
2011-12-11 02:50:16,6, GSM1: Checking memory size
2011-12-11 02:50:16,7, GSM1: -> AT+CPMS?
2011-12-11 02:50:16,7, GSM1: Command is sent, waiting for the answer
2011-12-11 02:50:17,7, GSM1: <- AT+CPMS?
+CPMS: ,,,,,,,,
OK

Member
Registered:
Jun 2009
Location: Russian Federation
1) please use correct command : sendsms 91xxxxxxxxxx 'test message'
2) please verify do you have /var/spool/sms/outgoing folder ?

Member
Registered:
Dec 2011
Location: HYDERABAD, India
Topic owner
Yes folder was created like as given and permission set to nagios

var/spool/sms/outgoing folder

Member
Registered:
Dec 2011
Location: HYDERABAD, India
Topic owner
Now getting sms alerts, just i changed mobile to CELLCON C9 MODEL.

Thanx

Login and Post Reply

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.