SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Mon Mar 01, 2021 12:21
SMSTools3 Community » Help and support Bottom

+CMS ERROR: 500 (Unknown error), slow sending

Login and Post Reply

Page:  1

Author Post
Member
Registered:
Aug 2011
Location: Santiago, Chile
Operating system name and version: Ubuntu Server 10.04
Version of smsd: 3.1.14
Smsd installed from: sources
Name and model of a modem / phone: Modem Pool with Siemens MC55
Interface: USB

First that nothing, thank you very much by this great software. I note that is much work and dedication..............
To, also say that my English is bad. Pardon by my errors.

I have a Pool of modems (16) working with SMSTools. It sends and it receives Ok messages. Nevertheless, an error (CMS ERROR: 500) causes that global Sending is slow. The exit, in rated burden is of about 8 to 10 seconds by modem, but when the error happens, it is delayed between 40 seconds to 1 minute in returning to send. I have proven many alternatives suggested in the forum: Fixed SMSC, Cel number in International format, memory_star=0, etc. but the error follows.
I verified my SIM and have OK, the SMSC in SIM is equal to definied in smsd.conf.......
I sending with smstools 7.000 sms or must, but troughtput is slow............. reason why I have been able to deduce, the problem is the error 500, that delays all the sending........ :'(

Mi smsd.conf:

#
devices = GSM1, GSM2, GSM3, GSM4, GSM5, GSM6, GSM7, GSM8, GSM9, GSM10, GSM11, GSM12, GSM13, GSM14, GSM15, GSM16
#
outgoing = /var/spool/sms/outgoing
checked = /var/spool/sms/checked
incoming = /var/spool/sms/incoming
logfile = /var/log/smstools/smsd.log
smart_logging = yes
infofile = /var/run/smstools/smsd.working
pidfile = /var/run/smstools/smsd.pid
outgoing = /var/spool/sms/outgoing
failed = /var/spool/sms/failed
sent = /var/spool/sms/sent
stats = /var/log/smstools/smsd_stats
report = /var/spool/sms/reports
status_signal_quality = yes
decode_unicode_text = yes
incoming_utf8 = yes
loglevel = 7
delaytime = 4
errorsleeptime = 3
blocktime = 120
max_continuous_sending = 100
ignore_outgoing_priority = yes
status_interval = 1
autosplit = 3
store_received_pdu = 3
store_sent_pdu = 3

[default]
#smsc = 5691600130
incoming = yes
baudrate = 19200
trust_spool = no
#init = ATE1+CMEE=1  
#pre_init = no          # fail with thats option
pin = ignore
status_signal_quality = no
report = yes
rtscts = yes
send_delay = 0
#mode = old
voicecall_hangup_ath = yes
hangup_incoming_call = yes
signal_quality_ber_ignore = yes
check_memory_method = 31
memory_start = 0


[GSM1]
device = /dev/ttyUSB1

[GSM2]
device = /dev/ttyUSB2
.......
.
.
.
 
 
'smsdconf' Syntax Highlight powered by GeSHi



And error log:



And, filter sending velocity from sms:


The error and slowness Aid is the same in all modems ............ please.

Thank you very much

Best Regards

Member
Registered:
Aug 2011
Location: Santiago, Chile
Topic owner
:| :'(
I have proven hundreds of configurations and profit not to solve the problem. Each 2 or 3 shipments, the modems enter error 500 and a blockade of about 20 to 30 seconds takes place.
In this moment, exact error is:

GSM2: <- +CMS ERROR: 500 +CMTI: "MT",1 (Unknown error)

This produces a great global delay of the speed of sending.


Very thanks

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
You could contact your GSM operator. Perhaps there are some limitations for sending, or GSM network/cell just is busy.

When SMS is first tried to send, CMS 500 is received in one second. Perhaps the modem has lost the connection to GSM network, and does not indicate it properly.

As you have this issue with all modems, you could try to send with one modem only, to see if the problem still exists. If it does not, increase the number of modems one by one to see when the problem begins.

Member
Registered:
Aug 2011
Location: Santiago, Chile
Topic owner
Keke.

The problem stays when having only 1 modem ...............
All modems are equal: Cinterion MC55i. The speed of sending is reduced only to 2 or 3 per minute ............... :oops:

Some idea?

Thanks

Member
Registered:
Aug 2011
Location: Santiago, Chile
Topic owner
After many days (I very very Ill :| ), I can return to write ..............
Now I removed the blockades from publicity. They are a good aid generally, to not have given account me of this in its site.

I warmly need some advice how solving the problem with the error that appears to me (CMS ERROR 500). They are being sent hardly 2 or 3 SMS per minute due to this error ................ I have a serious problems to send bulk sms................ :roll: :roll:

Thank you, very much.

Rodolfo

Member
Registered:
Aug 2011
Location: Santiago, Chile
Topic owner
Keke.

I investigated, very dificult...... but te bulk SMS in my country does not have norms. I have tried to secure the information without success............ The problem persists permanently. :'(

Now, I have my doubts with respect to if it is indeed the Cellular Network. This, because the experience of these last weeks me to since as more modems I place, slower the system is placed ......... for example, if pool of 24 modems, average of sending of each modems is every 30 seconds, however if it has 16 modems, average of each modem is of shipment every 20 seconds ...........!!!!!!

I have given thousands him of returns to this subject and non encounter solution. The advice who I have found in the forum have helped to improve some seconds, but the speed of global sending follows deteriorated.

It would request you could give me to a direct email for have private consultations to you.


Very been thankful

Been thankful.

Rodolfo Aravena

Member
Registered:
Apr 2010
Location: Buenos Aires, Argentina
Estimado Frodo:

Creo que tenemos el mismo problema y podemos compartir experiencias. Si deseas puedes escribirme a azagraorux@gmail.com

Lextor

Member
Registered:
Aug 2011
Location: Santiago, Chile
Topic owner
Gracias Lextor.
Excelente compartir experiencias en el idioma natal

Saludos y nuevamente agradecido

Member
Registered:
May 2011
Location: Caracas, Venezuela
Hola, tengo el mismo problema... Han encontrado alguna solucin o algun tips que me oriente en como puedo solucionarlo. Gracias

Member
Registered:
Jul 2012
Location: caracas, Venezuela
tengo algunos problemas quisiera hacer algunas preguntas en espaol! si pueden hablamos por correo "jpereira@gruporeveron.com"

Login and Post Reply

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.