SMS Server Tools 3
This site is hosted by Kekekasvi.com
 Menu
Basic information:
Additional information:
Support:
Get SMS Server Tools 3:
Additional Options

 Sponsored links

 Search
Custom Search

 Visitor locations
 
 SMS Server Tools 3 Community
Welcome, Guest. Please login or register. Sun May 19, 2024 20:56
SMSTools3 Community » Help and support Bottom

[solved] Problem baudrate

  This topic is locked

Page:  1

Author Post
Member
Registered:
Jul 2009
Location: Italy
Operating system name and version: Debian Linux 5.0
Version of smsd: 3.1.5
Smsd installed from: package repository
Name and model of a modem / phone: Siemens S53
Interface: Serial adapter Usb-to-rs232

Hi,
I had a problem like in the following post:
[solved] 3.1.3 works, but 3.1.5 makes trouble

I had fix problem changed the baudrate to 19200.
All works.
After, I tried to send a message and smstools works fine, stored message in incoming.
All ok.

After 2 minutes, it's stop to work: without changes!!

I post my tail -F /var/log/smsd.log



Why this??

Can anybody help me???


« Last edit by keke on Mon Nov 16, 2009 19:13, 176 months ago. »
Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Sorry, but I have no answer for this issue right now.

Some things I would like to confirm:

Before updating, you was running 3.1.3 with the same device and with the same USB-RS232 adapter? And it never hanged in this way?

Does this hanging always happen after a SMS is received, or does it happen randomly? If you run for example 30 minutes without receiving any SMS, there are no troubles?

Surely you are not running more than one daemon simultaneously (in the ps -efj list, there should be two smsd processes, one "mainprocess" and one "modem process", nothing more)?

Member
Registered:
Jul 2009
Location: Italy
Topic owner
keke wrote
Sorry, but I have no answer for this issue right now.

Some things I would like to confirm:

Before updating, you was running 3.1.3 with the same device and with the same USB-RS232 adapter? And it never hanged in this way?

Sorry, I explained badly: I never update! I always had the same version 3.1.5.
Before fix the problem (with the solved post above mentioned, but with the version 3.1.5) don't work, with the following error in log:
Siemens: -> AT
Siemens: Command is sent, waiting for the answer
Siemens: put_command expected (OK)|(ERROR), timeout occurred. 7.
Siemens: <-
Siemens: ->
Siemens: Command is sent, waiting for the answer
Siemens: put_command expected (OK)|(ERROR), timeout occurred. 8.


keke wrote
Does this hanging always happen after a SMS is received, or does it happen randomly? If you run for example 30 minutes without receiving any SMS, there are no troubles?

I received the SMS and, I think randomly, after 2 minutes it's hanging!!
But after it's never worked.
After receiving the SMS there was no problems, belonging to the error of the index of memory (2009-11-16 19:24:31,7, Siemens: <- +CMS ERROR: 321 (Invalid memory index)) that I have already corrected.

keke wrote
Surely you are not running more than one daemon simultaneously (in the ps -efj list, there should be two smsd processes, one "mainprocess" and one "modem process", nothing more)?

This is the answer:
Sms:~# ps -efj | grep sms
root 19307 19303 19307 19303 0 09:34 pts/1 00:00:00 tail -F /var/log/smsd.log
root 19317 1 19317 19317 0 09:35 ? 00:00:00 /usr/local/bin/smsd MAINPROCESS -p/var/run/smsd.pid -i/var/run/smsd.working -l/var/log/smsd.log
root 19319 19317 19317 19317 0 09:35 ? 00:00:00 /usr/local/bin/smsd Siemens____ -p/var/run/smsd.pid -i/var/run/smsd.working -l/var/log/smsd.log
root 19328 19286 19327 19286 0 09:36 pts/0 00:00:00 grep sms

It's wrong??

;) Tks in advance for help me!!

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
The process list is correct.

How many times you have tried and noticed the hanging? When hanging happens, you stop the smsd but also disconnect the adapter to get it working again? Do you need to reset the phone?

Some adapters work better with baudrate 115200, but in your case the phone does not support this speed. Can you try without the adapter, using a traditional RS232 port? Some times "real" RS232 ports work better than adapters.

If you do not have real RS-232 port, you could try to set rtscts = no, but this setting is not good in the normal usage. You can also try a lower baudrate, like 9600.

Member
Registered:
Jul 2009
Location: Italy
Topic owner
keke wrote
The process list is correct.

How many times you have tried and noticed the hanging? When hanging happens, you stop the smsd but also disconnect the adapter to get it working again? Do you need to reset the phone?

:oops: :oops: :oops: Sorry, sorry, sorry.
I fix the problem(i hope): my phone is discharged!!! :lol: :lol:
I'm sorry but I work remotely and I could not know if it was discharged :lol: :mrgreen:

keke wrote
Some adapters work better with baudrate 115200, but in your case the phone does not support this speed. Can you try without the adapter, using a traditional RS232 port? Some times "real" RS232 ports work better than adapters.

I tried without the adapter, but don't work.
This is my smsd.conf:

devices = Siemens
failed = /var/spool/sms/failed
sent = /var/spool/sms/sent
logfile = /var/log/smsd.log
loglevel = 7
stats = /var/spool/sms/stats
stats_interval = 3600
stats_no_zeroes = yes


[Siemens]
#init = AT&F
init = AT+CPMS="SM"
device = /dev/ttyUSB0
incoming = 2
memory_start = 1
baudrate = 19200
cs_convert = no
smsc = 393359609600
rtscts = no
When I connect directly on RS-232 I change device in device = /dev/ttyS0
I tried also a lower baudrate but don't work.

keke wrote
If you do not have real RS-232 port, you could try to set rtscts = no, but this setting is not good in the normal usage. You can also try a lower baudrate, like 9600.

If I set rtscts = yes don't work: error message: Modem is not clear to send

:lol: :oops: :lol: Sorry, sorry, sorry and sorry again!!!

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
Ok :)

By the way, why are you using cs_convert = no setting? This setting does not have an effect when you are sending or receiving Unicode messages, but normal SMS files are using GSM alphabet with cs_convert disabled. You have to manually convert your locale (which is what?) to GSM alphabet and vice versa.

Do you see some incorrect characters with internal ISO alphabet conversion? If so, please describe it so I can think if an additional character set table should be created. It's not a big job. For example the next version will have a table for ISO-8859-7 which is Greek alphabet.

Member
Registered:
Jul 2009
Location: Italy
Topic owner
keke wrote
Ok :)

By the way, why are you using cs_convert = no setting? This setting does not have an effect when you are sending or receiving Unicode messages, but normal SMS files are using GSM alphabet with cs_convert disabled. You have to manually convert your locale (which is what?) to GSM alphabet and vice versa.

Do you see some incorrect characters with internal ISO alphabet conversion? If so, please describe it so I can think if an additional character set table should be created. It's not a big job. For example the next version will have a table for ISO-8859-7 which is Greek alphabet.

If you mean in incoming message, I don't have incorrect characters!
This is a incoming message:

From: 393*********
From_TOA: 91 international, ISDN/telephone
From_SMSC: 3939*******
Sent: 09-11-16 19:23:57
Received: 09-11-16 19:24:32
Subject: Siemens
Modem: Siemens
IMSI: *****************
Report: yes
Alphabet: GSM
Length: 8

Try


Therefore should I use cs_convert = yes or nothing???

Administrator
Registered:
May 2009
Location: Jyväskylä, Finland
tokie wrote
Therefore should I use cs_convert = yes or nothing???

Yes. ;)

The setting cs_convert defaults to yes and applies for both outgoing and incoming messages.

You see correct characters because you only used US-ASCII. Digits, letters and some other characters are the same in GSM alphabet, but some characters are not. For example, @ is zero in GSM alphabet. There are also escaped characters, in extended character set. See GSM 03.38 character set for more details.

The built in conversion table is made with ISO-8859-15, which seems to be used in Italy too.

Member
Registered:
Jul 2009
Location: Italy
Topic owner
keke wrote
tokie wrote
Therefore should I use cs_convert = yes or nothing???

Yes. ;)

The setting cs_convert defaults to yes and applies for both outgoing and incoming messages.

You see correct characters because you only used US-ASCII. Digits, letters and some other characters are the same in GSM alphabet, but some characters are not. For example, @ is zero in GSM alphabet. There are also escaped characters, in extended character set. See GSM 03.38 character set for more details.

The built in conversion table is made with ISO-8859-15, which seems to be used in Italy too.

Ok! you're right!!
I tried to send this message:" Il servizio gi attivo" from Sms server with special characters like "" and "" and the result, on my celluar phone is the following:
"Il servizio C( giC attivo" (note also the space, is not my mistake!!)

I'll try without "cs_convert".

  This topic is locked

Page:  1

SMSTools3 Community » Help and support Top

 
Time in this board is UTC.  

Privacy Policy   SMS Server Tools 3 Copyright © Keijo Kasvi.